Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Rygar, The Legendary Adventure, slow down
#1
Hey I'm kinda new here, but this seems like really the only good place to go for help. I've been fiddling around and trying to fix my pcsx2 emulator for a while now. After a lot of tinkering, I got it to work on my FFX game flawlessly, with only the occasional slowdown that can be tolerated. Now I'm trying to play a game not many people may know, called "Rygar, the Legendary Adventure", and I keep getting slowdowns on gameplay, to the point where it's practically unplayable. Here's my computer specs from dxdiag:

OS: Windows 7 Home Premium 64-bit (6.1, Build 7601)
CPU: AMD Phenom ™ 9650 Quad-core Processor (4 CPUs), ~2.3 GHz
Memory: 8192 MB RAM
Graphics Card: NVIDIA GeForce GT 240 (4050 MB approx. memory)

I'm using the PCSX2 version 0.9.9 r5347.
Can anyone help me with this?
Reply

Sponsored links

#2
1. Download and use latest PCSX2 from HERE

2. Tick Native in GSdx

3. Enable speed hacks including MTVU

4. Play around with Allow 8-bit textures option in GSdx and see which one gives you more FPS

5. Go to Config -> Emulation Settings, at EE/IOP tab, change Clamp mode to None, the same goes for VU tab.
Reply
#3
First off, thanks for the reply. I tried what you said, and the FPS seems to stay at a normal 60 FPS like it should, but even with the FPS at the correct amount, the game itself is still slowed down, any ideas on what might be causing that?
Reply
#4
the only thing that causes that is the sliders in the speedhacks section, they can cause false FPS on games they dont really have any real effect on
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#5
Oh so I shouldnt use the sliders?
Reply
#6
Avoid it if you can, if you do use them, usually 1 notch on the left one and 1 or 2 on the right one are more than enough (if they will have an effect)

If it doesn't actually make a difference, it's better for the emulation to have them as off as possible.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#7
Okay thanks, I'll keep them on the first notch. Any other ideas on making the game stop having random slow spikes?
Reply




Users browsing this thread: 1 Guest(s)