Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
SMT: Sigital Devil Saga - Regular freezes
#1
Hey guys,

I started today to play SMT: Digital Devil Saga again, since I left it quite early but want to retry now. But I have a huge problem: The game freezes regularly when there are ingame graphics (which means always except for prerendered cutscenes). I'm quite frustrated, because I have no idea how to fix this. I tried every (reasonable) configuration, beginning from fooling with the clamp modes over switching from SuperVU to MicroVU and vis versa to even trying on Software Mode (Speed Hacks were the first things I disabled of course). None if this worked apparently. So I wonder: Do you guys have any ideas about what could be wrong with this game. I know that "some" of you already played it and I didn't find a thread in this forum where someone reported these freezes. Please, tell me your secret Tongue!

Regards,
Bright-Warrior
Rejoice, they say. Color is back.
Reply

Sponsored links

#2
Is it NTSC or PAL version of the game?

If the PAL version, you can try setting the PAL framerate to 59.97 just for this game, then enable "EE timing hack", it will help a lot for the freezes but it's not going to be perfect.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#3
(05-20-2011, 12:01 AM)Shadow Lady Wrote: Is it NTSC or PAL version of the game?

If the PAL version, you can try setting the PAL framerate to 59.97 just for this game, then enable "EE timing hack", it will help a lot for the freezes but it's not going to be perfect.

Ah yeah, sorry, I forgot that info. It's the PAL version of the game and in my opinion, it is working way worse than the last time I played it. There were freezes as well, but not so many and so regular. You can forget the part about this only happens with ingame graphics drawn, I've had three freezes in cutscenes by now...

How do I change the PAL framerate? I do see the number in the GS menu, but it's grayed so I can't change it.

P.S.: The EE timing hack is helping quite a lot. I fixed the problem with PCSX2 not finding the game database for some reason, but it would be located in a folder where I had an old version of PCSX2 quite some time ago. And the folder was deleted of course^^. I don't understand why PCSX2 is looking for the data base there, because not only did I delete the PCSX2 folder in "my documents" but I also compiled it from source, like the old version it is looking for as well. Do you have an idea why this is happening? Anyways, by fixing this (by simply create the so desired folder and putting the data base in it) the EE timing hack is now automatically enabled when the game starts. And it makes the game at least a bit more fluidly playable.

Regards,
Bright-Warrior
Rejoice, they say. Color is back.
Reply
#4
(05-20-2011, 12:31 AM)Bright-Warrior Wrote: How do I change the PAL framerate? I do see the number in the GS menu, but it's grayed so I can't change it.

I dont know if its possible through the gui anymore but you can change it via the ini file "PCSX2_vm.ini" just search for "FrameratePAL=50.0" and change it to whatever you like.
Specs:
CPU: C2D E8400 @ 3.6
GPU: GTX 560Ti 2Gb
MOB: Asus P5QL
RAM: Crucial 4Gb
OS: Windows 7 64bit/XP 32bit
Reply
#5
(05-20-2011, 12:42 AM)GamerGeek Wrote: I dont know if its possible through the gui anymore but you can change it via the ini file "PCSX2_vm.ini" just search for "FrameratePAL=50.0" and change it to whatever you like.

Thanks, this is working for me Smile . And finally Serph is not walking as slow as a slug anymore^^. Really, the 50 fps in the PAL version are just to few, it's really sad that this game has no NTSC modus. Ah well, it now has one after all Tongue.

Any ideas about the "issue" with the game database?
Rejoice, they say. Color is back.
Reply
#6
It may be looking for the old location from the registry.

I'd suggest just using the binary PCSX2 package and then you don't need to worry about other folders outside of the place you unpack it to:
http://forums.pcsx2.net/Thread-PCSX2-0-9...ows-Binary
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#7
(05-20-2011, 01:02 AM)Shadow Lady Wrote: It may be looking for the old location from the registry.

Yeah I had the same issue, entering the registry editor and manually changing the location to the current one does work. Although the portable version is just simpler.
Specs:
CPU: C2D E8400 @ 3.6
GPU: GTX 560Ti 2Gb
MOB: Asus P5QL
RAM: Crucial 4Gb
OS: Windows 7 64bit/XP 32bit
Reply
#8
(05-20-2011, 01:02 AM)Shadow Lady Wrote: It may be looking for the old location from the registry.

I'd suggest just using the binary PCSX2 package and then you don't need to worry about other folders outside of the place you unpack it to:
http://forums.pcsx2.net/Thread-PCSX2-0-9...ows-Binary

Nah, I think I stick with the SVN builds^^. The stable version is nice, but I'd like to have the newest changes. And since I create this folder I'm fine, I was just wondering if there is an easy solution for this. Like changing something in the .inis or something like that (I didn't find anything related to the data base in the inis though).

But I have another question, related to the changed framerate: Is it possible to create a custom framerate, that can be enabled by some F key or something like that? Because the game is now running pretty fast, as it should, but in FMV the audio is way behind the shown things (I'm using the Async mode of SPU-X). I think that this was available in a previous version of PCSX2, but I can't find it anymore.
Rejoice, they say. Color is back.
Reply
#9
No, what the old versions of PCSX2 did was simply set the frame limiter, you can still do the same by changing the frame limit base/slowmo/turbo toggles which are by default 100%/50%/200% and you can change them to whatever you want, then you can toggle them ingame with the Tab and Shift+Tab combination keys. This however is different to the NTSC/PAL framerates which deal with the synchronization. What you're experimenting currently with the FMVs being out of sync is because you changed the PAL framerate, to be in sync it should be set to the default 50FPS.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply




Users browsing this thread: 1 Guest(s)