Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
SOCOM CA artifacts and blink entities
#1
Hi,
First of all thanks for this amazing program. I am been using it for years (not continuous lol), though that doesnt mean I know what I am doing.

Im trying to correctly config SOCOM Combined Assault but I have two main problems. One is a big artifact that crosses the screen diagonally. Strangely enough, this artifact is only shown at both safe presets and balanced, it disappears on aggressive.

The other problem is enemies (and my people) blinking. I have had artifacts in Front Mission 4 but didnt care very much since that isnt an action game, but in this game it is game breaking for me. In this case the blinking is at safe, balanced and aggressive.

I use PCSX2 1.4.0. My system is Windows 10 x64 and specs i5 4570 and 8GB RAM, nVidia GTX 650 (no TI, no boost, no nothing version).

Thanks for your help
Reply

Sponsored links

#2
It is blinking means you are maybe using frameskipping. It is problem same for me in dbzbt3 with frameskipping at 2/2.
Disable it and then check it.
Reply
#3
Hi,
Thanks for your answer.

As far as I can tell, frame skipping isnt enabled. I only tried using the presets and its not enabled in any of them. I also tried disabling presets but not touching anything and frame skipping is still disabled, the first option "Disabled (default)".

By blinking I dont mean stuttering, I mean they totally disappear and appear again. Sometimes they totally disappear for a few seconds. But they only disappear graphically, they still shoot and get shot by my mates.
Reply
#4
it's a SPS issue that's related to either clamping or rounding on the VUs. Sadly, I'm not sure it can be fixed
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply
#5
I have been testing with that. With clamping extra and extra + preserve sign they dont seem to blink any more. The problem is those big artifacts it creates:

http://s25.postimg.org/6h3jo7y2n/Sin_t_tulo.png

These arent created in clamping: none, but then they blink and its impossible to aim.
Reply
#6
That was strange. After testing a while I got to a situation where I didnt have any more artifacts or blinking. It was with claming extra + sign and rounding to whatever, i tried all. However after restarting the program it started again with the artifacts...
Reply
#7
(02-25-2016, 09:08 AM)JohnE Wrote: That was strange. After testing a while I got to a situation where I didnt have any more artifacts or blinking. It was with claming extra + sign and rounding to whatever, i tried all. However after restarting the program it started again with the artifacts...
Did you switch to software mode(f9) and back(f9 again)? Sometimes graphicals errors are temporarily fixed that way.
Reply
#8
I could have pressed, but Im not sure.

Anyway I think I got it fixed! I think that the key settings are clamping mode in extra or extra+sign, for the blinking entities and EE cyclerate and VU cycle stealing both set to 0 for the artifacts. I completed the first mission without any artifact or blinking in 17 minutes.

Only one small thing that bothers me a bit. I think that the game seems to stutter a very very little bit, almost imperceptible and I think that slows down the game a very very little bit. If I take out frame limit the frames in game goes up to 170 FPS stable so I think its not the hardware. I even tried to speed up by 4% to have 54 fps but I still feel like it is slow. Maybe am I being too paranoid?
Reply
#9
Im having another problem. Its the particles, they slow down the game A LOT. Only certain objects cause particles, like the smoke of a generator, but that generator slows down the game in a 10 m radious, and its even worse if you have to switch it off.

Is possible to reduce the particles rendered? Or switch off them completely?
Reply
#10
Is not possible to do anything with particles? Sad Its very annoying to play in some levels.
Reply




Users browsing this thread: 1 Guest(s)