Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
SOCOM CA flashing/invisible NPCs
#1
Hello there,

I'm trying to get the SOCOM Combined Assault (PAL version) working but I can't seem to figure out how to fix the flashing and disappearing NPCs ingame. Sometimes I see nothing at all because of a gray screen which seems to appear only when I'm in a gunfight with the NPCs.

Is there a way to get this working?
I'm using the latest GIT build (Also tried pcsx2 1.0.0 according to the compatibility list, still the same)

I uploaded a GIF of what I mean - http://cdn.makeagif.com/media/2-05-2015/l5MGDP.gif

My specs:
CPU Intel Core i5 @ 2.67Ghz
GPU GeForce GTX 660
RAM 8GB
Reply

Sponsored links

#2
Try messing around with VU settings. I think setting VU0 to interpreter, Round mode to negative/nearest and clamping mode to None should fix most of the problems you described but it will slow down the game a bit.

You can also try other combinations to find out what works best.
Reply
#3
Are you using any non-default settings ?
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#4
I tried messing up with EE and VU settings, it seems that I fixed the flashing NPCs (and gray screen) by setting the VU clamping mode to "Extra + Preserve Sign" but then some of the textures began to "stretch" across the screen.

I can get rid of the "stretching" textures by setting the VU clamping mode to "None" but then I'm back to where I was with the flashing NPCs... The game also isn't smooth, it's a little laggy but playable. The main problem are the textures now Sad
Reply
#5
Hey I guess I just somehow made it work Laugh I'll post the setting screens here
Reply
#6
Here it is for the people who will have the same problem, it's in the czech language but I think it won't be a problem, hope it helps Smile cheers

P.S. bios used US v2.20 (10/02/2006)


Attached Files Thumbnail(s)
                   
Reply
#7
(02-05-2015, 05:28 PM)DeathFish Wrote: Here it is for the people who will have the same problem, it's in the czech language but I think it won't be a problem, hope it helps Smile cheers

P.S. bios used US v2.20 (10/02/2006)

Are you sure these settings work correctly? I checked these and it still suffers from spikey polygons. Only settings that work correctly are the ones I described in my first post.
Reply
#8
I guess it's individual, but these are working for me. But I have another question for you Mr. prafull.

Me and my friend have the latest version of hamachi, we are in the same room, we turned off the firewalls and still couldn't see each other in the LAN game.

Is there any chance you knew where the problem is?
Reply
#9
(02-05-2015, 06:37 PM)DeathFish Wrote: I guess it's individual, but these are working for me. But I have another question for you Mr. prafull.

Me and my friend have the latest version of hamachi, we are in the same room, we turned off the firewalls and still couldn't see each other in the LAN game.

Is there any chance you knew where the problem is?

You may have missed a step or wrong settings may be? I can join and try to help you guys if you want. Give me your hamachi channel details.
Reply
#10
(02-05-2015, 06:44 PM)prafull Wrote: You may have missed a step or wrong settings may be? I can join and try to help you guys if you want. Give me your hamachi channel details.

That would be very generous of you, thank you. I'll PM you tomorrow then If you don't mind and then we can discuss it via hamachi chat? Smile
Reply




Users browsing this thread: 1 Guest(s)