Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
(SOLVED) ppa wants to remove xorg!
#1
Ubuntu 14.04.3 with vivid HWE stack! 

i previously had pcsx2 1.3 installed through tar.xz and it worked great!
Now i cannot install pcsx2 1.4.0 because it tries to remove vivid xorg and put in original xorg and that will break my system!

tar.xz of (1.4.0) doesn't work either, because:

ERROR the plugin (./plugins/libGSdx-intel-sse4-1.0.0.so) miss some dependencies
    ./plugins/libGSdx-intel-sse4-1.0.0.so: /usr/lib/i386-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by ./plugins/libGSdx-intel-sse4-1.0.0.so)
./plugins/libGSdx-intel-sse4-1.0.0.so: /usr/lib/i386-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by ./plugins/libGSdx-intel-sse4-1.0.0.so)

ERROR the plugin (./plugins/libspu2x-2.0.0.so) miss some dependencies
    ./plugins/libspu2x-2.0.0.so: /usr/lib/i386-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by ./plugins/libspu2x-2.0.0.so)
./plugins/libspu2x-2.0.0.so: /usr/lib/i386-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by ./plugins/libspu2x-2.0.0.so)
libSDL2-2.0.so.0 => not found
libwx_baseu-3.0.so.0 => not found
libwx_gtk2u_core-3.0.so.0 => not found
libwx_gtk2u_adv-3.0.so.0 => not found

ERROR the plugin (./plugins/libGSdx-avx2-1.0.0.so) miss some dependencies
    ./plugins/libGSdx-avx2-1.0.0.so: /usr/lib/i386-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by ./plugins/libGSdx-avx2-1.0.0.so)
./plugins/libGSdx-avx2-1.0.0.so: /usr/lib/i386-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by ./plugins/libGSdx-avx2-1.0.0.so)

ERROR the plugin (./plugins/libGSdx-1.0.0.so) miss some dependencies
    ./plugins/libGSdx-1.0.0.so: /usr/lib/i386-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by ./plugins/libGSdx-1.0.0.so)
./plugins/libGSdx-1.0.0.so: /usr/lib/i386-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by ./plugins/libGSdx-1.0.0.so)

ERROR the plugin (./plugins/libonepad-1.1.0.so) miss some dependencies
    libSDL2-2.0.so.0 => not found

./PCSX2: error while loading shared libraries: libwx_baseu-3.0.so.0: cannot open shared object file: No such file or directory


ppa error:

sudo apt-get install pcsx2
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libglew1.10:i386 linux-headers-3.19.0-25 linux-headers-3.19.0-25-generic
  linux-image-3.19.0-25-generic linux-image-extra-3.19.0-25-generic
  linux-lts-vivid-tools-3.19.0-31 linux-signed-image-generic
  linux-tools-3.19.0-31-generic nvidia-cuda-gdb opencl-headers
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libegl1-mesa libegl1-mesa:i386 libegl1-mesa-drivers libgbm1:i386
  libgl1-mesa-dri libgl1-mesa-dri:i386 libgl1-mesa-glx libgl1-mesa-glx:i386
  libglapi-mesa libglapi-mesa:i386 libgles2-mesa libopenvg1-mesa
  libsdl2-2.0-0:i386 libwayland-egl1-mesa libwayland-egl1-mesa:i386
  libwxbase3.0-0:i386 libwxgtk3.0-0:i386 xserver-xorg xserver-xorg-core
  xserver-xorg-input-evdev
Suggested packages:
  libglide3 libglide3:i386 xfonts-100dpi xfonts-75dpi
The following packages will be REMOVED:
  libegl1-mesa-lts-vivid libegl1-mesa-lts-vivid:i386 libgbm1-lts-vivid
  libgbm1-lts-vivid:i386 libgl1-mesa-dri-lts-vivid
  libgl1-mesa-dri-lts-vivid:i386 libgl1-mesa-glx-lts-vivid
  libgl1-mesa-glx-lts-vivid:i386 libglapi-mesa-lts-vivid
  libglapi-mesa-lts-vivid:i386 libgles1-mesa-lts-vivid libgles2-mesa-lts-vivid
  libwayland-egl1-mesa-lts-vivid libxatracker2-lts-vivid
  xserver-xorg-core-lts-vivid xserver-xorg-input-all-lts-vivid
  xserver-xorg-input-evdev-lts-vivid xserver-xorg-input-mouse-lts-vivid
  xserver-xorg-input-synaptics-lts-vivid xserver-xorg-input-vmmouse-lts-vivid
  xserver-xorg-input-wacom-lts-vivid xserver-xorg-lts-vivid
  xserver-xorg-video-all-lts-vivid xserver-xorg-video-ati-lts-vivid
  xserver-xorg-video-cirrus-lts-vivid xserver-xorg-video-fbdev-lts-vivid
  xserver-xorg-video-intel-lts-vivid xserver-xorg-video-mach64-lts-vivid
  xserver-xorg-video-mga-lts-vivid xserver-xorg-video-neomagic-lts-vivid
  xserver-xorg-video-nouveau-lts-vivid xserver-xorg-video-openchrome-lts-vivid
  xserver-xorg-video-r128-lts-vivid xserver-xorg-video-radeon-lts-vivid
  xserver-xorg-video-savage-lts-vivid
  xserver-xorg-video-siliconmotion-lts-vivid
  xserver-xorg-video-sisusb-lts-vivid xserver-xorg-video-tdfx-lts-vivid
  xserver-xorg-video-trident-lts-vivid xserver-xorg-video-vesa-lts-vivid
  xserver-xorg-video-vmware-lts-vivid
The following NEW packages will be installed:
  libegl1-mesa libegl1-mesa:i386 libegl1-mesa-drivers libgbm1:i386
  libgl1-mesa-dri libgl1-mesa-dri:i386 libgl1-mesa-glx libgl1-mesa-glx:i386
  libglapi-mesa libglapi-mesa:i386 libgles2-mesa libopenvg1-mesa
  libsdl2-2.0-0:i386 libwayland-egl1-mesa libwayland-egl1-mesa:i386
  libwxbase3.0-0:i386 libwxgtk3.0-0:i386 pcsx2:i386 xserver-xorg
  xserver-xorg-core xserver-xorg-input-evdev
0 upgraded, 21 newly installed, 41 to remove and 11 not upgraded.
Need to get 21,2 MB of archives.
After this operation, 63,8 MB of additional disk space will be used.
Do you want to continue? [Y/n] n
Abort.

i hope this gets fixed soon. 
Thanks in advance!

EDIT: nevermind it is ubuntu's fault

sudo apt-get install libsdl2-2.0-0:i386
has the same issue
Reply

Sponsored links

#2
Well, tar.xz was built on my system which still use the old C++ ABI. Or maybe you miss the 686 optimizations "libc6-i686:i386"

The issue seems to be related to mesa or wayland (there are often the culprits)

You could try to upgrade only mesa.
Code:
apt-get install   libegl1-mesa libegl1-mesa:i386
Reply
#3
Hi gregory,

the problem is that those packages (libegl1-mesa libegl1-mesa:i386) are the original trusty ones. i have already installed the vivid ones from the LTS enablement stack https://wiki.ubuntu.com/Kernel/LTSEnablementStack (libegl1-mesa-lts-vivid libegl1-mesa-lts-vivid:i386) and "libc6-i686:i386" is already installed as well!
libsdl2 wants to replace my whole xserver with the old one. Filed a bug report on launchpad.

btw g++ --version

g++ (Ubuntu 4.8.4-2ubuntu1~14.04.1) 4.8.4
Copyright © 2013 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
Reply
#4
I built the binary with gcc4.9 and libstdc++6 4.9

Edit: I'm not sure that PCSX2 will work too (after the SDL2 fix)
Reply
#5
(02-20-2016, 02:13 PM)gregory Wrote: I built the binary with gcc4.9 and libstdc++6 4.9

Edit: I'm not sure that PCSX2 will work too (after the SDL2 fix)

yes that is a problem... i only have 4.8 (and so do most 14.04/mint 17 users i think). Is it possible to recompile it on 4.8?
Reply
#6
SDL2 issue solved, so i can install ppa now and it runs correctly! Thx for help anyways
http://askubuntu.com/questions/736944/so...grade-xorg
Reply
#7
How did you solbe it?
Reply
#8
i followed the instructions in the link, basically:

sudo apt-get install libwayland-egl1-mesa-lts-vivid:i386
sudo apt-get install pcsx2

after upgrading to vivid HWE stack i didnt install all vivid 32-bit packages, so this happened!
Reply
#9
Thanks. It could be useful for someone else in the future.
Reply




Users browsing this thread: 1 Guest(s)