Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
SOUND DELAY?!?!
#1
Hello all,

I'm new to the PCSX2 program and forum and am trying to resolve a problem with the sound on my computer. I have seen similar problems on this forum but no definitive fixes.

The problem is that no matter when running different games or even just the PS2 bios, there is always a sound delay of two to three seconds. Button sounds, cutscenes, intros, etc. all have a sound delay. There is no video or processing delay and I am running at around 60 fps except for parts of games that require lots of processing "juice".

I have tried switching to the different sound plugins but that didn't help either.

I currently sport a 2011 13" 2.3Ghz i5 4GB macbook pro with an Intel HD 3000 graphics card.

Anyone else have this problem and know how to fix it?

Thanks in advance
Reply

Sponsored links

#2
Culprit: Intel HD 3000 graphics card
Custom Desktop
CPU: Ivy Bridge Core i5 3570 3.4 GHz (3.8 GHz w/ Turbo Boost)
CPU Instructions: MMX, SSE1, SSE2, SSE3, SSSE3, SSE4.1,
SSE4.2, EIST, iAMT2, Trusted Execution Technology (TXT)
OS: Windows 7 Professional 64-bit
RAM: 8192MB DDR3 SDRAM PC3-10600 1333
HDD: 1 TB Western Digital HDD
Video: MSI GeForce GTX 660 2 GB GDDR5
Audio: Realtek 5.1 HD Audio
Reply
#3
have you tried disabling every option in the sound options? That fixed a 1-2 second delay for me. even though is says recommended it messed mine up.
13" 2010 Mac Book Pro - Snow Leopard 10.6.7 - Pcsx2 Version: 0.9.6 (and praying on 0.9.7 to release)
2.4Ghz Intel Duo Core | NVIDIA 320M (256mb) | 4 Gigs 1067mhz DDR3 Ram

Reply
#4
(07-06-2011, 05:40 AM)nintendo85 Wrote: Culprit: Intel HD 3000 graphics card

not at all.

Time stretching is always the culprit with the default buffer length

lowering it to 70 helps but its still there if you're hypersensitive to latency.
Reply
#5
(07-06-2011, 09:29 AM)mubbsy Wrote: have you tried disabling every option in the sound options? That fixed a 1-2 second delay for me. even though is says recommended it messed mine up.

That had no effect whatsoever for me. The sound was still about 2 seconds delayed.

Thanks anyway though.
(07-06-2011, 12:01 PM)Squall Leonhart Wrote: not at all.

Time stretching is always the culprit with the default buffer length

lowering it to 70 helps but its still there if you're hypersensitive to latency.

How do I lower it to 70? I looked in all the config windows but couldn't find it.

Thanks
Reply
#6
I think you're looking for this:
   
Reply
#7
(07-06-2011, 05:41 PM)miseru99 Wrote: I think you're looking for this:

Unless I'm mistaken, I don't believe that sound plugin is compatible with macintosh. Are there any other plugins for macintosh other than ZeroSPU playground 0.4.6 (which works with latency) or SPU2null 0.8.0 (which doesn't seem to work at all)?
Reply
#8
Aw sorry, didn't notice it was mac section, Squall probably either =_=; ZeroSPU doesn't seem to have such option at all.
Reply
#9
At this point I'll just recommend the usual again:
Use bootcamp to install Windows XP and then use the Windows PCSX2 version Tongue2
Reply
#10
(07-06-2011, 06:46 PM)rama Wrote: At this point I'll just recommend the usual again:
Use bootcamp to install Windows XP and then use the Windows PCSX2 version Tongue2

Alas, PCSX2 for windows definitely has gotten a head start.
However, I am pretty sure that other macintosh users do not have any sound delay, which makes me want to get to the bottom of this... maybe the 0.9.7 mac release will fix this problem, whenever it comes out. And maybe my graphics card does play a part in the problem too, since it is the only downgrade from previous macbook pro models, even though I have the sandy bridge processor.

Anyone else have an entry-level macbook pro? If you have the 2011 model, does your sound delay at all?
Reply




Users browsing this thread: 2 Guest(s)