Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
SPU issues.
#1
I'm running openSuSE Linux Tumbleweed. And I cannot get sound working with the various SPU plugins. The ones i've tried are:

catch22bbs:/usr/lib/pcsx2 # l *spu*
-rwxr-xr-x 1 root root   79720 Oct 20 03:04 libspu2PeopsALSA.so.1.0.3*
-rwxr-xr-x 1 root root   74564 Oct 20 03:04 libspu2PeopsOSS.so.1.6*
-rwxr-xr-x 1 root root  478628 Oct 20 03:02 libspu2x-2.0.0.so*
-rwxr-xr-x 1 root root 3901264 Oct 20 03:04 libspu2-x.so*
-rwxr-xr-x 1 root root  570988 Oct 20 03:04 libspu2x.so*

catch22bbs:/usr/lib/pcsx2 # l *SPU*
-rwxr-xr-x 1 root root  30088 Oct 20 03:04 libSPU2null.so*
-rw-r--r-- 1 root root 132615 Oct 20 03:04 libZeroSPU2.0.4.6.so
-rwxr-xr-x 1 root root 136272 Oct 20 02:59 libZeroSPU2.so.0.1.0*

I've noticed there are some *cfg* files. Any idea where I put them? And could the lack of those config files be the cause of having no audio?
My PCSX2 directory is /usr/lib/pcsx2 And also, the "config directory" is ~/.config/PCSX2

I've noticed when I do try to use those plugins, I get a segfault everyt ime.

Can anyone help out?

Thanks.
Reply

Sponsored links

#2
Well, i've made some progress. Here's my emuLog.txt file:

"
PCSX2 1.5.0-0
Savestate version: 0x9a0b0000

Host Machine Init:
        Operating System =  Linux 4.7.5-1-default x86_64
        Physical RAM     =  7887 MB
        CPU name         =  Intel® Core™ i3-6100 CPU @ 3.70GHz
        Vendor/Model     =  GenuineIntel (stepping 03)
        CPU speed        =  3.692 ghz (4 logical threads)
        x86PType         =  Standard OEM
        x86Flags         =  bfebfbff 7ffafbbf
        x86EFlags        =  2c100000

x86 Features Detected:
        SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2.. AVX.. AVX2.. FMA

Installing POSIX SIGSEGV handler...
Reserving memory for recompilers...
(GameDB) Database Not Found! [/usr/share/pcsx2/GameIndex.dbf]

Loading plugins...
        Binding   GS: /usr/lib/pcsx2/libGSdx-0.1.16.so
        Binding  PAD: /usr/lib/pcsx2/libonepad-1.1.0.so
        Binding SPU2: /usr/lib/pcsx2/libZeroSPU2.0.4.6.so
        Binding CDVD: /usr/lib/pcsx2/libCDVDiso.so
        Binding  USB: /usr/lib/pcsx2/libUSBnull-0.7.0.so
        Binding   FW: /usr/lib/pcsx2/libFWnull-0.7.0.so
        Binding DEV9: /usr/lib/pcsx2/libdev9null-0.5.0.so
Plugins loaded successfully.

        HotSwapping to new ISO src image!
HLE Notice: ELF does not have a path.


Initializing plugins...
        Init GS
        Init PAD
        Init SPU2
        Init CDVD
        Init USB
        Init FW
        Init DEV9
Plugins initialized successfully.

Patches: No CRC found, using 00000000 instead.
Opening plugins...
        Opening GS
glX-Version 1.4 with Direct Rendering
Supported Opengl version: 4.3 (Core Profile) Mesa 12.0.3 on GPU: Mesa DRI Intel® HD Graphics 530 (Skylake GT2) x86/MMX/SSE2. Vendor: Intel Open Source Technology Center
Buggy driver detected. Geometry shaders will be disabled

INFO: GL_ARB_separate_shader_objects is supported
INFO: GL_ARB_gpu_shader5 is supported
INFO: GL_ARB_shader_image_load_store is supported
INFO: GL_ARB_clear_texture is not supported
INFO: GL_ARB_buffer_storage is not supported
INFO: GL_ARB_shader_subroutine is not supported
INFO: GL_ARB_explicit_uniform_location is supported
INFO: GL_ARB_texture_storage is supported
INFO: GL_ARB_shading_language_420pack is supported
INFO: GL_ARB_multi_bind is not supported
INFO: GL_ARB_bindless_texture is not supported
INFO: GL_NV_depth_buffer_float is not supported

        Opening PAD
        Opening SPU2
ALSA lib pcm.c:2450Sadsnd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2450Sadsnd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2450Sadsnd_pcm_open_noupdate) Unknown PCM cards.pcm.side
ALSA lib pcm_route.c:867Sadfind_matching_chmap) Found no matching channel map
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
ZeroSPU2: Initialized portaudio...
ZeroSPU2: Created sound stream successfully...
ZeroSPU2: Started sound stream successfully...
/home/abuild/rpmbuild/BUILD/pcsx2/common/src/Utilities/Linux/LnxHostSys.cpp(70) : assertion failed:
    Function:  void SysPageFaultSignalFilter(int, siginfo_t*, void*)
    Thread:    EE Core
    Condition: false
    Message:   Unhandled page fault @ 0x00000001
/home/abuild/rpmbuild/BUILD/pcsx2/common/src/Utilities/Linux/LnxHostSys.cpp(70) : assertion failed:
    Function:  void SysPageFaultSignalFilter(int, siginfo_t*, void*)
    Thread:    EE Core
    Condition: false
    Message:   Unhandled page fault @ 0x00000001
    Thread:    EE Core
    Condition: false
    Message:   Unhandled page fault @ 0x00000001

[00] wxSizer::Add(wxWindow*, wxSizerFlags const&)
[01] __kernel_rt_sigreturn
[02] 0x0xf10fecd1
[03] std::vector<wxString, std::allocator<wxString> >::~vector()
[04] std::vector<wxString, std::allocator<wxString> >::_M_fill_insert(__gnu_cxx::__normal_iterator<wxString*, std::vector<wxString, std::allocator<wxString> > >, unsigned int, wxString const&)
"
Reply
#3
Only spu2x is supported. I don't even know how you manage to compile those plugins. And your gsdx plugin is far from the git 1.5. My guess is that you have the 1.5 that was tagged a couple of day after 1.4. You need to take the 1.5 from latest git.
Reply




Users browsing this thread: 1 Guest(s)