Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
SPU2-X: Question about sound adapting to game speed
#1
Hey guys,

I got a small question: Is it possible to deactivate the ability of SPU2-X, that, if there's a slowdown, the sound is slowing as well? I hope you know what I mean. I tried to disable time-stretching, but this caused pretty choppy audio. But the sound wasn't slowed down anymore. Is there another way to disable this slowing down?

Another question, which will likely be answered with "No."^^: Is there a way to deactivate just the BGM of a game? So that you just hear the sound of the game itself (like swords, guns aso.) and not some background music as well? Because this happened to me with Persona 3 FES, which was sure a bug. But I liked it somehow^^.
Rejoice, they say. Color is back.
Reply

Sponsored links

#2
No and no. Deactivating time stretching WILL cause choppy audio if you don't get full speed, that's why it's enabled by default
[Image: newsig.jpg]
Reply
#3
(01-07-2010, 10:54 PM)Bositman Wrote: No and no. Deactivating time stretching WILL cause choppy audio if you don't get full speed, that's why it's enabled by default

Well, I thought so. Makes sense after all, but it was worth a try. Thanks for the answer though!
Rejoice, they say. Color is back.
Reply
#4
mmm you can try to go to advanced options under time-streching options and set all 3 sliders to their maximum value (90-32-25) i think that was the order from first to last slider Tongue
[Image: 2ymccqu.jpg]
[Image: 17715.png]
Reply
#5
(01-08-2010, 02:57 PM)diegochiha Wrote: mmm you can try to go to advanced options under time-streching options and set all 3 sliders to their maximum value (90-32-25) i think that was the order from first to last slider Tongue

What effect is this intended to have? Should this deactivate the slowing or just reduce it? Because it slows down after all, but I can't really say if it's less or as before.
Rejoice, they say. Color is back.
Reply
#6
It doesn't have any good effect for the problem you want to fix. It only changes the mixing parameters for the timestretched audio slices.

The rule applies for any synchronized SPU2 plugin.
If the game speed is not 100%, audio has to be sped up or slown down, or else you get audio skips.

The alternative would be an unsynchronized plugin (like peops SPU2), but that only works on the few games that don't rely
on the SPU2 to run in sync with the rest of the system.
Reply
#7
for me it just get the slowdown to be a little less "heavy",but if rama says it dont do nothing i really dont know
[Image: 2ymccqu.jpg]
[Image: 17715.png]
Reply
#8
(01-09-2010, 03:16 AM)rama Wrote: It doesn't have any good effect for the problem you want to fix. It only changes the mixing parameters for the timestretched audio slices.

The rule applies for any synchronized SPU2 plugin.
If the game speed is not 100%, audio has to be sped up or slown down, or else you get audio skips.[...]

I thought so, because I didn't really saw or heard a difference. And I usually (and unfortunately...) always notice such things.

(01-09-2010, 03:16 AM)rama Wrote: [...]The alternative would be an unsynchronized plugin (like peops SPU2), but that only works on the few games that don't rely
on the SPU2 to run in sync with the rest of the system.

I found an alternative for this. It was just nerving me, that in some dialogues in Persona 4 I get great slowdown. This itself isn't the problem, but the voices are sounding very bad, it's almost stuttering. But enabeling VU Cycle Stealing with "slight" gives me full speed sound, but just slow motion graphics^^. But this doesn't really bother me, I just like the voice actors so much^^. And my CPU comes down at 58% again^^. Speedhacks can be very interesting at times.

Thanks for the answers again!

Edit: Peops SPU2 is unfortunately not working for Persona 4 anyway.
Rejoice, they say. Color is back.
Reply




Users browsing this thread: 1 Guest(s)