Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Savage Skies Invisible creatures
#1
Recently grabbed Savage Skies for my pcxs2 emulator and I started it up, all seems well until I go into training. The actual creature won't show. The effects of it landing show and everything, but for some reason the actual mount doesn't? Not sure why, and when I looked it up, it doesn't seem like this is a common issue, so Im assuming its simply the settings I have or something like that.


Specs:
windows 8.1 64 bit
Proc: Intel Core i7-4790 3.60 GHz
Ram: 16 GB
Graphics: Nvidia Geforce GTX 760 ti

Emu settings:

http://imgur.com/CQLO785
http://imgur.com/IcmFLSG
Reply

Sponsored links

#2
why did you enable HW hacks ?
which ones did you enable ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
(08-21-2016, 08:35 PM)jesalvein Wrote: why did you enable HW hacks ?
which ones did you enable ?

The box is ticked, but none are enabled, which is why I didn't post a screenshot of the window. I unticked it when I noticed it, left over from another game, and it made no difference.
Reply
#4
This issue still hasn't been fixed, Thanks!
Reply
#5
Does it show when you press F9 (switch to software renderer)? If so switch from Direct3D 9 (Hardware) to Direct3D 11 (Hardware), if that doesn't help switch to OpenGL (Hardware) and enable "Hardware Depth".
Reply
#6
(08-21-2016, 10:20 PM)FlatOut Wrote: Does it show when you press F9 (switch to software renderer)? If so switch from Direct3D 9 (Hardware) to Direct3D 11 (Hardware), if that doesn't help switch to OpenGL (Hardware) and enable "Hardware Depth".

No, they don't show on software, I've tried hardware direct 11, and opengl hardware, with depth enabled. None of this seems to have an effect on the mount showing. Anything else I can try? I'm honestly at a loss here and I really want to play this game.
Reply
#7
you could try an old build.
according to the compatibility list, this game (provided you own the US version) worked on an older build. could be a regression
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#8
Go to Config > Emulation Settings > VUs tab, and change the Clamping Mode or Round Mode setting to one of the other options and see if the creature shows up.
Reply
#9
(08-22-2016, 07:48 AM)jesalvein Wrote: you could try an old build.
according to the compatibility list, this game (provided you own the US version) worked on an older build. could be a regression
I think I'm gonna try this honestly, because I was fooling around in the singleplayer and such, and it seems to have the game breaking bug listed, which is that it won't get past the mission objectives screen. It freezes each time without fail.

In response to changing the VUs, I'll give it a go, though I'm not sure it'll get me past the freezing, even if it gets the creature to show back up, thank you though.

I'll update this with another post after I try both.
Reply
#10
Go to Config > Emulation Settings > Game Fixes tab, click "Enable manual game fixes" and tick the box of "EE timing hack". It might solve the freeze.
Reply




Users browsing this thread: 1 Guest(s)