Thread Rating:
  • 16 Vote(s) - 4.88 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ScpToolkit (XInput Wrapper aka ScpServer Reloaded)
Hopefully someone on this thread can help me. I hope I'm not posting this in the wrong place.
I was running SCPToolkit on my PC for PC based games (Max Payne 3 and GTA IV). It worked great, but I had to format and reinstall everything and that's when the controller started acting up.

I am running the most up-to-date SCPToolkit but am having trouble with 1 action. When I hold down L2 (to aim) and tap R2 (to shoot) the character doesn't shoot. I have tried uninstalling and reinstalling the SCPToolkit a few times. I am not sure how to clear and re-install the drivers so I just overwrite the drivers each time, but the outcome is always the same.

I am able to use the buttons independently and all other buttons seem to respond while I hold down L2 it just seems to be the combo of L2 and R2 not playing nicely together.
If anyone has any insight as to what to look for or possibly even change that would be great I am really lost on how to solve fix this issue for myself.

*Quick note. If I hold down L2 to aim and hold down R2 to shoot then let go of L2, the character shoots. Not sure if this info helps at all.
Reply

Sponsored links

Thanks for this great tool however I am having a slight problem. I am pretty sure I have done everything correct so what do I do to actually use my ps3 controller after I press install? Help would be much appreciated. Thanks in advance
Reply
(01-16-2017, 04:59 PM)nate51 Wrote: Hopefully someone on this thread can help me. I hope I'm not posting this in the wrong place.
I was running SCPToolkit on my PC for PC based games (Max Payne 3 and GTA IV). It worked great, but I had to format and reinstall everything and that's when the controller started acting up.

I am running the most up-to-date SCPToolkit but am having trouble with 1 action. When I hold down L2 (to aim) and tap R2 (to shoot) the character doesn't shoot. I have tried uninstalling and reinstalling the SCPToolkit a few times. I am not sure how to clear and re-install the drivers so I just overwrite the drivers each time, but the outcome is always the same.

I am able to use the buttons independently and all other buttons seem to respond while I hold down L2 it just seems to be the combo of L2 and R2 not playing nicely together.
If anyone has any insight as to what to look for or possibly even change that would be great I am really lost on how to solve fix this issue for myself.

*Quick note. If I hold down L2 to aim and hold down R2 to shoot then let go of L2, the character shoots. Not sure if this info helps at all.
*SOLVED*

I uninstalled everything (drivers from the driver tool, app from the installed apps) then installed DirectX and then installed the SCPTool and everything is now working. I found this out by installing an older version of SCPToolkit and noticed the new package doesn't seem to install DirectX. Hope this helps anyone who has encountered a similar issue.
Reply
Hey everyone,

I have got a pretty weird problem with this program. Yesterday I downloaded ScpToolkit and installed all the drivers so I could use my Dualshock 3 on Windows 7 (64-bit) (via a USB-cable). It all worked great and I used the controller for a couple of hours.

Then today I start up my PC, plug in the Dualshock 3 and suddenly I am greeted with a blue screen of death and total system crash......Rebooted PC, tried again, another blue screen. Then I set the program to only boot up manually (instead of automatically on start-up), but as soon as it started up and connected the controller my PC crashed again. Finally I tried to use my Dualshock 4 controller instead, but the exact same thing happened (blue screen of death as soon as controller connected).

Anyone know what's up? It worked perfectly yesterday.....
Reply




Users browsing this thread: Rendabomb, 25 Guest(s)