Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Screen flashing/flicker like issue
#1
Find the issue a bit hard to describe, but recently tried playing my suikoden 3 copy and there are weird flashes/flickers when playing. It happens in windowed and full screen mode. It seems to be mostly located at the upper half of the screen.

Using: PCSX2 1.2.1.r5873 - compiled on Feb 3 2014
Windows 7, 6gb ram, Intel I7 930 @ 2.8ghz, nvidia GTX580 332.21.

Settings:

Everything on the emulation settings page is left on default.
Pad and audio plugins i haven't touched either.
Video plugin i'm using is: GSDx 5875 ( SSE41 ).
- Scaling is at 4x native.
- Direct3D11 ( hardware )
- interlacing: none
- The rest is have left on default.

I have tried:

- Older version of PCSX ( 1.1 )
- Using native res
- The various interlacing methods ( though, blend bff does help, i think )
- Software mode
- Direct3d9
- Not using widescreen patch
- ticking the wait for vsync on refresh ( at first i thought it was tearing, but it looks far worse then any tearing i have ever seen )
- disabling all speed hacks


Edit: My copy of Dragon Quest 8 seems fine
Reply

Sponsored links

#2
Are you running at full speed?

is this happening in-game or in videos?
Reply
#3
Yeah, full speed no slowdowns. It is too slow without the speed hacks though.

It is ingame. The anime cutscene at the start had no issues.
Reply
#4
Can you please show us your settings.
Lenovo Y50-70 Gaming Laptop
Intel Core i7-4720HQ @ 2.6Ghz - 3.6Ghz Quad Core
Nvidia GTX 960M 4GB
8GB DDR3 Ram
15.6'' Full HD 1920 x 1080 IPS
Windows 10 64 Bit
---
Intel Core i5 4670 @ 3.4Ghz
Gigabyte H81M
Gigabyte Radeon R9 280X 3GB
8GB DDR 3 Ram
1TB WD Black
Windows 10 64 Bit
Phillips 23.6" 1920x1080 IPS
Reply
#5
Here are all my settings. I also tried making a vid of the problem, but haven't had much luck with that yet ...

In addition:
- i have the manual game fixes disabled, as recommended.
- Automatic game fixes turned on
- Enable widescreen patch on ( as mentioned, have tried with this disabled )

Edit: what it actually looks like is that it's quickly trying to redraw the screen or part of the screen... it's really funky


Attached Files Thumbnail(s)
                           
Reply
#6
On GSdx, try to check 'Enable HW hacks', then click 'Configure', then check 'NVIDIA Hack'.

Alternatively, try DX9 instead of DX11.

Let us know if any of those helped.
[i7-3630qm/gt650m-2G/Win-7] [i7-4500u/R.HD8850m/Win-8.1] [2010-MBA/OSX-10.9.x]. Scroll smoothly with SmoothWheel for Firefox.
Reply
#7
(02-16-2014, 11:54 PM)avih Wrote: On GSdx, try to check 'Enable HW hacks', then click 'Configure', then check 'NVIDIA Hack'.

Alternatively, try DX9 instead of DX11.

Let us know if any of those helped.

He did already try DX9.

Also try enabling 8-bit textures.

Edit: You are not the first one to have this problem. - http://forums.pcsx2.net/Thread-Suikoden-...tings-help

That guy solved it by disabling MTVU, but I see you don't have it enabled anyway.

Try disabling MVU Speedhack.

You might wanna untick vsync for now too.
Lenovo Y50-70 Gaming Laptop
Intel Core i7-4720HQ @ 2.6Ghz - 3.6Ghz Quad Core
Nvidia GTX 960M 4GB
8GB DDR3 Ram
15.6'' Full HD 1920 x 1080 IPS
Windows 10 64 Bit
---
Intel Core i5 4670 @ 3.4Ghz
Gigabyte H81M
Gigabyte Radeon R9 280X 3GB
8GB DDR 3 Ram
1TB WD Black
Windows 10 64 Bit
Phillips 23.6" 1920x1080 IPS
Reply
#8
(02-17-2014, 12:02 AM)Donovan24 Wrote: He did already try DX9.

Also try enabling 8-bit textures.

Edit: You are not the first one to have this problem. - http://forums.pcsx2.net/Thread-Suikoden-...tings-help

That guy solved it by disabling MTVU, but I see you don't have it enabled anyway.

Try disabling MVU Speedhack.

You might wanna untick vsync for now too.

- Nvidia hack didn't help
- 8 bittextures neither
- vsync is off now, didn't do help anyway
- tried opengl as well, but nope

I read that thread before i posted and several others, but couldn't find a solution. I tried the mvu suggestion in it.

Edit: only new nvidia drivers are in beta, would rather not install those ...
Reply
#9
(02-17-2014, 12:20 AM)Eket Wrote: - Nvidia hack didn't help
- 8 bittextures neither
- vsync is off now, didn't do help anyway
- tried opengl as well, but nope

I read that thread before i posted and several others, but couldn't find a solution. I tried the mvu suggestion in it.

I read somewhere that it doesn't flicker in ZeroGS but it has alot of other problems then. So probably not really worth it.
Lenovo Y50-70 Gaming Laptop
Intel Core i7-4720HQ @ 2.6Ghz - 3.6Ghz Quad Core
Nvidia GTX 960M 4GB
8GB DDR3 Ram
15.6'' Full HD 1920 x 1080 IPS
Windows 10 64 Bit
---
Intel Core i5 4670 @ 3.4Ghz
Gigabyte H81M
Gigabyte Radeon R9 280X 3GB
8GB DDR 3 Ram
1TB WD Black
Windows 10 64 Bit
Phillips 23.6" 1920x1080 IPS
Reply
#10
(02-17-2014, 12:26 AM)Donovan24 Wrote: I read somewhere that it doesn't flicker in ZeroGS but it has alot of other problems then. So probably not really worth it.

Think it might be a problem with my setup(nvidia seems to have some issues with pcsx2). I have seen vids on youtube with the game running great and with upscaling. They don't really list versions and settings tho. But honestly most settings are very straightforward, hard to really mess it up.

ZeroGS crashed 3 times for me. I stopped trying to get it to work.

Edit: tried star ocean and xenosaga a long time ago on pcsx2 1.1 those did work fine tho
Reply




Users browsing this thread: 1 Guest(s)