Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Screwy fog emulation in Neopets: The Darkest Faerie
#1
When using PCSX2 v1.5.0-dev-1964-g815ac8b, Neopets: The Darkest Faerie has some bizarre fog emulation going on. Here's a video:


Anyone have any idea why this happens?
Reply

Sponsored links

#2
In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
openGL or dx?
Reply
#4
Okay:

Specs:
Intel Core i5-7300HQ CPU @ 2.50GHz
8GB DDR4 RAM
NVIDIA Geforce GTX 1050 Ti
Windows 10 Home 64-bit


PCSX2 Settings:
DirectX 11
MTVU speedhack enabled
Vsync on
Mipmapping set to basic in GSdx
Internal resolution set to 2x native
Anisotropic filtering set to 2x
CRC Hack Level set to full
MSAA set to 2x
Fast texture invalidation enabled
Reply
#5
use OpenGL (Hardware), set the CRC hack level to "partial" and make sure the blending accuracy is on at least "basic", it might improve being higher but I don't think it's needed.

The blending is hacked in DX so it may not appear correctly.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#6
When I do that, the fog flat out disappears.
Reply
#7
I don't think it disappears, it just isn't prominent in the foreground.

But no fog is better than horrible looking fog Wink

As you can see here, it's supposed to be faint and distant https://gamefaqs.akamaized.net/screens/2...4_2_22.jpg
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#8
Fogs are often related to depth effect.
Reply
#9
Well, except for some tearing, it seems to be working like it does on a real PS2. Thanks!
Reply




Users browsing this thread: 1 Guest(s)