Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Seeing through geometry in SMT Nocturne
#1
Posted this in the GSdx thread proper, but it might deserve its own thread as well.

Simply put: I can see through geometry in Shin Megami Tensei Nocturne. Apparently this issue cropped up a couple years ago and was more or less fixed, but somehow I'm having it. No amount of fiddling with settings will solve this (except for going into software rendering, but I don't really want to do that since it looks terrible), I assure you I have tried flipping every switch within reach.

I'm using the latest version of PCSX2, which apparently comes with GSdx 0.1.16, having upgraded from PCSX2 0.9.8 specifically in attempts to solve this issue. All my specs that I can figure would be relevant here:

OS: Windows 7 Home Premium, 64-bit
Processor: Intel Core i7-2720QM
Graphics card: NVidia GeForce GT 540M, 1GB
RAM: 8 GB

[Image: rjrTWDr.jpg]

If anything else is needed to figure out what's causing this, I'll be happy to oblige.
Reply

Sponsored links

#2
Please post your game CRC as calculated by PCSX2. You can find it in the log when starting up the game.
Reply
#3
(02-05-2013, 05:55 PM)rama Wrote: Please post your game CRC as calculated by PCSX2. You can find it in the log when starting up the game.

Strangest thing about that, the console hasn't been printing it. I got this when opening the game (we've been puzzling it out on Something Awful, we don't know why there either).

Quote:(GameDB) 9640 games on record (loaded in 154ms)
HLE Notice: ELF does not have a path.


Initializing plugins...
Init GS
Init PAD
Init SPU2
Init CDVD
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

Opening plugins...
Opening GS
Opening PAD
Opening SPU2
Opening CDVD
isoFile open ok: C:\Users\PC\Documents\PCSX2\SMTNOCTURNE.mdf
Image type = DVD
Fileparts = 1
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (2085072 sectors)
Opening USB
Opening FW
Opening DEV9
McdSlot 0: C:\Users\PC\Documents\PCSX2\memcards\Mcd001.ps2
McdSlot 1: C:\Users\PC\Documents\PCSX2\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
Bios Found: Europe v01.60(04/10/2001) Console
BIOS rom1 module not found, skipping...
BIOS rom2 module not found, skipping...
BIOS erom module not found, skipping...
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
(UpdateVSyncRate) Mode Changed to PAL.
(UpdateVSyncRate) FPS Limit Changed : 50.00 fps
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
(UpdateVSyncRate) Mode Changed to PAL.
(UpdateVSyncRate) FPS Limit Changed : 50.00 fps
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps

That's where the on-boot messages end. I know there's meant to be more, it just doesn't turn up.
Reply
#4
Well your game doesn't get detected, which most likely mean it was modified somehow(or pcsx2 has a strange bug when reading mdf), and when it doesn't get detected, customized hacks for the game doesn't work, that's why you're getting those glitches.

Try running from original, unmodified disc using cdvd plugin(select "plugin" under CDVD menu and if you have more than one drive, select it in cdvd plugin config) and if it works, make a standard iso with imgburn, once it get detected your problem should disappear as well.
Reply
#5
Other ISOs aren't doing it either, actually. I just checked my copies of Final Fantasy XII and Sonic Mega Collection Plus, the emulator doesn't print it with any of them.

...I suppose we've found the problem here, and it happens to not be with what I thought it was, huh?
Reply
#6
You may have to enable "verbose" logging in the console options.
Reply
#7
No go there. I actually just enabled everything in the console's options, just on a hunch that something, somewhere in there, will present what I want.

I'm beginning to see that this is an issue beyond plugins, so I'm going to open a 'general support' thread as well.
Reply




Users browsing this thread: 1 Guest(s)