Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
September 2015 progress report
#21
I read a longs time ago that it wasn't possible but I didn't check the information. Quickly asking my best friend, it seems to be possible (but need to check all the OS). Anyway, MMX is barely used but it requires lots of extra code to manage the MMX register and the MMX state. Removing MMX would make recompiler code easier. And therefore easier to port.
Reply

Sponsored links

#22
I see. Thank you for the information.
Reply
#23
If 1.4.0 is releasing soon, then we need to:

- Prepare for another widescreen archive update (lots of updates)

- Change the background (I already have a mock-up 1.4.0 I made a while back - if anyone has suggestions, let me know)

[Image: OL1NBvx.png]

- Add Pokopom Xinput controller plugin (I already talked to KrossX and they're fine with it), because the emulator should be Xinput-ready.
Reply
#24
They? Is krossx a group?
Also lilypad supports xinput?
Reply
#25
http://forums.pcsx2.net/Thread-Pokopom-K...Pad-Plugin

KrossX is a member of our forum, and he made an AWESOME controller plugin called Pokopom, which is superior to Lilypad in my opinion because you don't have to configure anything as long as you have an Xinput controller.

It definitely needs to be added in PCSX2 as an available plugin.

I'm not a Github member, so someone else will have to do it.

I believe Pokopom v2.1-4.zip is the best version.
Reply
#26
Quote:which is superior to Lilypad in my opinion because you don't have to configure anything as long as you have an Xinput controller.

KrossX added that to lilypad lately, it's done automatically now.
Reply
#27
(01-04-2016, 12:49 AM)K.F Wrote: KrossX added that to lilypad lately, it's done automatically now.

It's not working for me. What do I have to do?

I'm using the latest Lilypad plugin in the latest build.
Reply
#28
If you have an Xinput pad plugged in, nothing. It should be already mapped for both pads 1 and 2, you can see it in the lilypad settings window. Make sure your controller is set as xinput #1 in Windows - "Xinput pad 0" for lilypad -.
Reply
#29
(01-04-2016, 01:31 AM)K.F Wrote: If you have an Xinput pad plugged in, nothing. It should be already mapped for both pads 1 and 2, you can see it in the lilypad settings window. Make sure your controller is set as xinput #1 in Windows - "Xinput pad 0" for lilypad -.

I think it's set as Xinput pad 2, and I don't see where to change it to 0.

It says Pad 0 and Pad 1 have DX USB Receiver in them (I assume they're my wireless mouse and wireless keyboard?), but I shouldn't have to change USB ports in order to make this work.
Reply
#30
Yeah, it is a pain in Windows to change the pad port number, I usually need to uninstall and remove all the problematic devices, restart the pc, then install the devices again in the needed order, and even that sometimes fail for no reason.

It would be great if the plugin detected the device directly, or if it asked for a single button to be pressed, then fill the rest.

Anyway, in your case, backup and open "LilyPad.ini" in the inis folder, and search for "Instance ID=XInput Pad 0" then change 0 to 2, and it should work for you then.
Reply




Users browsing this thread: 1 Guest(s)