Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Settings for playing Persona 3 FES?
#1
I'm trying to play persona 3 FES, but I keep getting weird graphical errors. Like nothing is visible inside the tartarus except for my characters weapons. Thankfully it is fine during battles, but there are just times where the screen goes nearly completely black, or a weird color stripe pattern appears on the ground in front of my character. If anyone has this game working perfectly, could I get you to share your graphics settings? Thanks.

--------
blakekl
Reply

Sponsored links

#2
Alright, after searching around some more I realized I forgot to check the game fixes section. I activated the one that is supposed to fix ground geometry for persona games, hoping this would solve the problem. It didn't though. I'm posting some attachments now so you can see what I'm dealing with. Most of the time, inside tartarus anyways, the first screen shot is what I see. Occasionally, the floor will appear and other objects sometimes, although not correctly. Note the transparency of the stairs. Tartarus is creepy enough when I CAN see. Smile


Attached Files Thumbnail(s)
       
Reply
#3
Try disabling frameskip.

AFAIK the game isn't playable in the mac version yet, I could be wrong, try doing a search for it in this section.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#4
Have you checked no log z in zzogl settings?
Reply
#5
Ok, so I just started playing Persona 3 FES on my 2010 macbook. I use 0.9.6 for snow leopard but I'm not sure if that makes a difference. I HAVE gotten graphics to work almost perfectly in Tartarus (there are a couple glitchy lines on the ground and sometimes the screen goes black for a few seconds), and perfectly just about everywhere else. It's slow for me, ESPECIALLY when characters are speaking, but that's probably just because my computer isn't powerful enough. The settings I use are as follows:

Graphics:
No bilinear filtering
4x AA
Under advanced options for graphics:
No target resolves on
No color clamping on
Resolve hack #1 on
Fast Update on
Partial depth on
No logarphmic Z on
and everything else off.

Game Fixes:
VU Clip Hack on
everything else off.

Under speed hacks:
EE Sync Hacks turned up to x2 Cycle Rate
VU Cycle Stealing turned to 0
Enable IOP x2 Cycle Rate on
INTC Sync Hack on
Idle Loop Fast-Forward on
Status Flag Hack on


Using these settings, Tartarus should look the way it does in the attached image.
Incidentally, are you getting the slowdown when characters talk as well? If so, have you found any way around it?


Attached Files Thumbnail(s)
   
Reply
#6
yeah, P3 is just slow on zzogl it seems, I experience the same even on the alpha 0.9.7 with zzogl-pg so nothing to do really
Reply
#7
i get the slow down whet people are talking too, but not very bad. Worse is the audio lag, but I'm sure zedr0n is already aware of that issue. Your settings didn't seem to help. In fact, it made the whole screen black right from the start. Couldn't see the logo's or the opening scene or the menu. I did get the floor and walls to show up initially by default settings + no logarphmic z and partial depth, but that only worked once. I did discover, however, that talking to one of my party members or opening a chest fixes the issue until I get into a battle or I open the menu. Essentially, if something covers the current screen, like a dialog window, it fixes it. It's really weird. Discovering this does make the game playable though, at least.
Reply
#8
Yeah, the No logarphmic Z seemed to be the thing to make everyone look normal here too.

If we are talking about the audio slow down that makes all the voice acting weird I have a fix that's somewhat visible (because at times you can see the game skip frames after all) but it did fix 90% of the speech slow down on P4 and I played a first part of P3 FES to check and it seems to work there too.

Go to CPU settings then enter these numbers on the right from top to bottom and make sure to enable frame skip:

61 (which is the framerate max)
55 (if it drops below this point it will start skipping frames)
2 (this is how many frames it has to stay below the minimum before it starts skipping)
2 - 12 (the amount of frames it will skip. The worse the problem the higher you need to go)

The second and last number you can tweak around with to get the best visual performance, but in my case it made all the voice acting as clear as day.

I hope this will help you towards your solution Smile
Reply
#9
Don't know if anyone is still tracking this, but my solution was actually to switch to an old version of the emulator for this game. Look up r1888 of the emulator. Then I'm using "Gsdx 1406 (MSVC 15.00 SSE2) 0.1.15" for the graphics plugin and "ZeroSPU2 r1455 0.4.6". It seems like other versions of the emu, no matter how I configure them have some issues, even the most recent one is far worse than this setup for Persona 3, but with those versions of the emu and plugins I got a pretty good effect.

Only issues I've been able to locate:
-> The menus lag a little bit behind the input. Only noticeable on the name entry screen at the beginning of the game though.
-> In the player menu, under S. Links, the character portraits have the drop shadows placed on top of the portrait, rather than behind. All other menus are fine.

The work it took to set this up was definitely worth it. I almost always have my laptop with me, console not so much.

(Note, this was the Windows version of the emulator.)
Reply
#10
Note, this is the Mac port section....
[Image: newsig.jpg]
Reply




Users browsing this thread: 1 Guest(s)