Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Shadow Of The Colossus Blank Screen
#1
So I've been looking around the forum for a while now and I can't find anyone with the same problem as I have.

I'm using PCSX2 0.9.6, and I'm trying to run SotC. I've enabled speed hacks (X3 and all the options on the right) and lowered the resolution, and I've also lowered the quality of the graphics displayed.
I can run SotC, but during the intro it slows down to around 4 FPS. I told myself, hey, if this is playable, I don't care about the intro. So I skipped that and started a new game (taking the time to set Progressive Scan to On in the options). During the cinematics I once again skipped, and I reached the part where someone says, "Now, be on thy way".

Supposedly you can start playing from there, but all I get is a white screen with a circle and a dagger on the bottom right part of the screen.

My PC specs, and the options set in PCSX2:
Intel Core 2 Duo E4500 @2.2 GHz (features: MMX, SSE, SSE2, SSE3, SSSE3)
NVidia GeForce 7600 GT
Windows 7 64-bit
2GB RAM

PCSX2 0.9.6, compiled on Feb 27 2009
ZeroGS 0.97.1
-> Anti-Aliasing: None
-> 640x480
-> No Target Resolves
Linuz Iso CDVD 0.8.0
CPU options: EErec, Vu0rec, Vu1rec and MTGS are on. Frame limiting is on.
Speed hack options:
Use x3 cycle rate
INTC Sync Hack
Enable IOP x2 cycle rate
WaitCycles Sync Hack

That should be enough info, but if you need anything else just ask Smile
Reply

Sponsored links

#2
Try switching your Graphics plugin to GSdx and try the latest beta which can give you some more speed:

http://forums.pcsx2.net/thread-3716.html
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#3
I downloaded the beta, and used GSdx. First of all, GSdx would only load when I used DirectX 9 (although I believe I have 11 installed).

The game loaded correctly and didn't show the blank screen from before, so we've had PROGRESS! Laugh
Although the FPS were at around 25... Would there be any way for me to run the game at 60 FPS? I'll post the plugin settings here again (since I changed plugin versions.... >.> )

GSdx 1873 (MSVC 15.00, SSE2) 0.1.15
-> Resolution 640x480 75 Hz
-> Renderer Direct3D9 (Hardware)
-> Interlacing: None
-> Aspect Ratio 4:3
-> D3D Internal Res: 768x768 (I read somewhere that this would be a good internal resolution for SotC)
-> On: Texture Filtering, Allow 8-Bit Textures, Logarithmic Z, Alpha Correction (FBA), Windowed
SPU-2X 1.2.0
-> Default settings
Linuz ISO CDVD 0.9.0 pointing at the ISO for SotC

CPU:
All options enabled. Limiting frames to normal.

Speed hacks:
x2 cycle rate.
EE Misc Hacks are all on.
Status Flag Hack is on.

Also, when I try to use Renderer Direct3D11 (Hardware) this is the log for the error:

Code:
PCSX2 beta (r1888) - compiled on Sep 20 2009
Savestate version: 8b410001
x86Init:
    CPU vendor name =  GenuineIntel
    FamilyID  =  d
    x86Family =  Intel(R) Core(TM)2 Duo CPU     E4500  @ 2.20GHz
    CPU speed =  2.199 ghz
    Cores     =  2 physical [2 logical]
    x86PType  =  Standard OEM
    x86Flags  =  bfebfbff 0000e39d
    x86EFlags =  20100000

Features:
    Detected MMX
    Detected SSE
    Detected SSE2
    Detected SSE3
    Detected SSSE3
    Not Detected SSE4.1
    Not Detected SSE4.2

Loading plugins...
Plugins loaded successfully.
Hotkeys:
    F1  - save state
    (Shift +) F2 - cycle states
    F3  - load state
Resetting...
Ready
Initializing plugins...
Plugins initialized successfully.
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (1315408 sectors)
Bios Version 2.0
Bios Warning > rom1 not found.
Bios Warning > rom2 not found.
Bios Warning > erom not found.
Framelimiter rate updated (UpdateVSyncRate): 59.94 fps
Opening Plugins...
MTGS > Thread Started, Opening GS Plugin...
MTGS > GSopen Finished, return code: 0xffffffff
An unhandled or unrecoverable exception occurred, with the message:

%s

Pcsx2 will now close.  More details may be available via the emuLog.txt file.
Closing plugins...
Plugins closed successfully.
Shutting down plugins...
Plugin shutdown complete.
Reply
#4
You do not have a Directx10/11 card that's why you can only use Direct3D9.

To get extra speed I'd suggest set the "VU Cycle Stealing" speedhack to moderate (maybe higher, up to you), also you might need to tick the "native" checkbox in GSdx since you don't have a powerful graphics card and Shadow of the Colossus needs a bit of it.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#5
Well native resolution doesnt get to much FPS.
Around 1-10. Depends on the game. And playing SOTC with VU Cycle Stealing is very difficult and yet annoying cuz the gameplay is very laggy and its really hard to play like this. (I know it.. i tried it myself with my "old" system. Now it runs fine Laugh)
Many games running full speed. o.O
Win XP SP3
Intel C2D E5200 @ 3,125 Ghz
2 GB RAM @ 800 Mhz
Sapphire ATI Radeon HD 4670

Weeeiiiird Laugh




Reply
#6
Oh. That's a pity about DirectX10/11.

It's working better now, at a 70% rate (around 40 FPS). I only activated the minimal VU cycle stealing, but I bet it will get better. If not, it's still playable.

Thanks a lot! Smile
Reply




Users browsing this thread: 1 Guest(s)