Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Shadow of the Colossus is getting way too bright - Help!
So in short my problem is that as soon as I get anywhere over the horizon of the game, the sunlight grows brighter and brighter until I'm able to see anything (see picture below).

I run on a Nvidia GeForce 9800 GTX+ 512 Mb and get up to 120 fps easily. This is my only problem so far and I've tried but failed to find a solution on the web.

[Image: sotc.jpg]

My config is:

[Image: speccs.jpg]

I hope there's someone out there that can help me since I really do like this game!


Sponsored links

I think unticking "native" in GSdx does the trick.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Yep, use an internal resolution higher than native. Uncheck the native box and use something like 1080x1080. Shadow of the Colossus is an extremely intensive game so you won't be able to raise the resolution as high as other games such as FF X or Kingdom Hearts.

You have pretty much the same hardware configuration as me (9800 GTX + E8400 @ 3.3 GHz here).

Try setting the internal resolution to 1080x1080 or some resolution of similar 'surface area.'

If you want check out the configuration in my signature you can find really good settings for the game. Shadow of the Colossus, yet another game I play in PCSX2 a lot Laugh

Everything in my settings will be what you need, except SOTC requires the use of some VU Cycle Stealing (set it to one or two notches higher than none) to run nicely at higher internal resolution than native.
Check out my snazzy Youtube channel, with many great PCSX2 emulation videos! Laugh Laugh
Tried it, but all I'm getting out of changing it to another resolution than Native is a whole lot of screen flickering at some places and a letterbox-kinda black bar at the bottom and the right side of the screen =(

Any other way I could get away the Bright Light without removing the img quality?
have you tried software or dx9 modes?
Nope will do that right now.

Did it, the letterbox is gone but the flickering persists =(
I found the solution, I reduced the EE cycle to x2 instead of x3 (which even suggests x3 for Colossus Ohmy)!
If you want to get a good speed boost in SotC without using EE Sync Hacks, get the latest beta and set VU Cycle Stealing to max. It gives a huge boost for this game and has no side effects.
OS: Windows 7 64bit
CPU: Intel Core i7 3770K @3.5 GHz
RAM: 16GB DDR3 1600MHz
GPU: Nvidia GTX 680 2GB

Users browsing this thread: 1 Guest(s)