Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Shenanigans with BT3
#1
I've got an Intel i7-3820 @ 3.6ghz but overclocked to 4ghz and an AMD 7970 running windows 7 ultimate. However, it's impossible for me to break 60fps on any game (PCXS2 1.0.0) and specifically Budokai Tenkaichi 3, which can go down to even 23fps. I've run the game with everything else turned off except task manager + real temp to try and identify the source of the problem. Task manager seems to think it never uses more than 17% of my cpu and 1.85gb of my available RAM, and my temps never go above 55 degrees (Celsius)

Now in this state it seems to flicker between 55ish fps, however if I begin recording with literally any software (frap, action!, d3d and dxtory are the ones I've tried) it goes down to 23 fps but cpu usage never goes higher than 23%. I've posted in their support forums and all of them say it's a problem with PCSX2. "CPU bottleneck" is repeatedly mentioned but no-one seems to want to explain what that is or how to fix it. Recording disregarded, the wiki says:


CPU: Intel core I7 860@ 2.8Ghz (Core 2 Duo with 3.0 Ghz+)
GPU: ATI Radeon HD 4650DP 2GB (A 1GB Graphics Card with Pixel Shader 3.0)
Comments: Full Speed @ 83 fps Constant. This Game is Medium Demanding.

How the hell are they getting such high speeds? How is a 2.8ghz computer out performing a 4ghz computer? Surely this means shenanigans are occuring within PCXS2? If this is something clearly not related to the program then I'll keep looking. Any ideas?
Reply

Sponsored links

#2
That's not a proper bug report, you should rather post in support section. Guessing on lack of info alot of things could happen.

First of all check GSdx settings, make sure you use DX11 hardware renderer, check "allow 8 bit textures" and don't use any overkill upscalling, x4 should be ok for test, also turn off MSAA if you turned it on, not only it causes some extra glitches which this game is already full of anyway it can also cause an extra slowdown.

If it still lags checking if your cpu/gpu clocks are high when you run pcsx2 would be nice, low gpu clocks could be caused by AMD catalyst drivers, which in the past already had stupid fail with top end gpu's(ie it doesn't happen on budget gpu's :X) not running at full power with PCSX2(and supposedly it was similar with dolphin). Some users got better results with different drivers, sometimes it was randomly going faster with different GSdx versions and sometimes creating 3D profile for pcsx2 in CCC(catalyst control center) was also helping with it. It's not really about shenanigans in pcsx2, but rather about hardware being optimized for PC games and ps2 ones have different limitations, hence power saving states doesn't deal with emulators properly. Ultimately you can run the game in software mode that's only way to show all of the game graphics properly anyway since it has alot of glitches and most post processing effects are removed in hw mode, 4ghz ivy should have no problem with doing it.

In case those were also not happening(through the driver problem is pretty hard to be sure of;p) it could easily be caused by some extra software especially ones like game boosters are usually crap for emulators, or even a virus, but that's unlikely.
Reply
#3
Ah, sorry. I thought this was the only support forum. Thanks so much though! Not sure if I can give rep on this site..
Reply
#4
So the problem solved?:3 Settings helped or it turned out to be something else? Anyway you're welcome.
Reply
#5
Are you using MTVU?

If not you are using only 2 of 8 logical cores which would reproduce 25% in the taskmanager if the cpu is in the limit.

By using MTVU you can get up to three threads which would correspond to 37.5%. I would not expect to see higher values in the taskmanager if you disregard antivirus software (which you probably have turned off).

You can improve the usage of the cores by setting the affinity to different cores in the taskmanager. I don't know which logical cores are using the same physical core. Probably either 1-2, 3-4, 5-6, 7-8 or 1-5, 2-6, 3-7, 4-8. pcsx2 shoud be separated from the other programs.

You can also disable hyperthreading but have to reboot everytime you to it if I remember correctly.

Maybe you first check MTVU and later you can test other stuff (as changing internal resolution and watch framerate to determine gpu-limits)
Reply




Users browsing this thread: 1 Guest(s)