Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Shin Megami Tensei III: Nocturne overall runniing at ~50% (30-35 fps)
#1
Hello,

I'm trying to play SMT: Nocturne on my laptop. I'm new to this emulator, so I don't know if I'm doing anything wrong. The game is playable, but it's running down to 30 fps constantly. I've attached some of my specifications to this post. I've fiddled around with settings, and I Think I've improved it a little, but nothing seems to help it to the point of actually being able to play it without being constantly annoyed with it. Is there anything wrong with any of my hardware? Is there anything I can do to speed up the game a little more?


Attached Files Thumbnail(s)
   

.txt   log.txt (Size: 2,64 KB / Downloads: 193)
Reply

Sponsored links

#2
(07-17-2011, 11:29 PM)atim Wrote: Hello,

I'm trying to play SMT: Nocturne on my laptop. I'm new to this emulator, so I don't know if I'm doing anything wrong. The game is playable, but it's running down to 30 fps constantly. I've attached some of my specifications to this post. I've fiddled around with settings, and I Think I've improved it a little, but nothing seems to help it to the point of actually being able to play it without being constantly annoyed with it. Is there anything wrong with any of my hardware? Is there anything I can do to speed up the game a little more?

ur lap have a igpu?? or amd/nvidia, also plz post ur pcsx2 settings, and ru using hacks?
Reply
#3
PCSX2 settings? Plugin settings? What do the EE/GS% numbers in game window say when you get slowdowns?
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#4
My GPU is a Radeon HD 6570.

I am using the recommended hacks, and they seemed to improve the speed. Without them, it seems to get worse. The plugins are all default. Is there an easier way to post the settings here without taking screenshots of every window? Which settings are most important?

EE runs at 97-100%, while I get FPS at about 38. GS hovers from around 17% to 24%

Edit: I went ahead and took those screenshots. Is there anything wrong here that you can see?


Attached Files Thumbnail(s)
                       
Reply
#5
(07-18-2011, 11:23 PM)atim Wrote: My GPU is a Radeon HD 6570.

I am using the recommended hacks, and they seemed to improve the speed. Without them, it seems to get worse. The plugins are all default. Is there an easier way to post the settings here without taking screenshots of every window? Which settings are most important?

EE runs at 97-100%, while I get FPS at about 38. GS hovers from around 17% to 24%

Edit: I went ahead and took those screenshots. Is there anything wrong here that you can see?

Seems like ur cpu is the bad guy >_>, apart the hacks, try changing the clamp mode in VU an EE to none-zero-nada-zip whatever says in ur pcsx2 ^^. And be sure to play the game @native resolution.

Edit: for some reason i coudl not see the pics, change the vu cycle to 1, if i remember 2 slowdown the game >_>
Reply
#6
I'd suggest you reduce the clamping from that VU clamping to normal.

Also as ecchiless said, your CPU is not that great, you could try setting the power profile in control panel to "high performance" and forcing PCSX2 to run in 2 cores but I wouldn't expect too much of a speedup.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#7
Hahah, so it's only running under one core? Sorry, I'm not familiar with all of this. How would I force it?

Thank you for the suggestions. I'll try them out. I'll let you know if I get much of a turnout.
Reply
#8
PCSX2 uses 17 threads, if I remember correctly (see it in Resource Monitor). But there's only 2 major threads using for emulate the EE and GS. If your CPU is dual core, there's nothing to do. But if your CPU is quad-core (indeed it is), the stupid Windows always tries to devide the workload to all cores, which ruins the TurboBoost without any FPS increase. To force PCSX2 to run on 2 cores, right click the PCSX2 process and click "Set affinity...". Choose core 0 and core 2 (or core 1 & core 3, ect...) because your CPU has HyperThreading.
Intel Core 2 Quad Q9400 | nVidia GeForce GTX 750 | 4 GiB DDR3 @ 533 Mhz | MSI G41M-P28 | Cooler Master RS-390-PMSR-A3 | Xigmatek TYR SD962 | LG Flatron W1943SE | HP KB-0316 | MotoSpeed F60
Reply
#9
Sweet. I don't know what it was, guys, but it works fantastically. I set the settings at what you suggested, and I'm running at 2x the native resolution, with no slowdowns. Funnily enough, it may have been something as simple as playing while in power saving mode. I'm not sure, but it couldn't have helped things. Thank you for pointing that out.

Livy, thank you for describing how to manage the workload/processes. I did try that, to see if it helped any more, and it seemed to slow down significantly. Unless I misunderstand something, I'm just going to leave all my settings the way they are, and enjoy my game. But that's a useful trick. I didn't know you could do that. I'll remember it.

Thank you for your help everyone!
Reply




Users browsing this thread: 1 Guest(s)