Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Shin Megami Tensei: Persona 3 FES FPS help
#1
Hey guys,

I've been trying to play Persona 3 FES on the computer, but aside from the art texture problems (which have been documented and accounted for already), I seem to be getting quite a dip on the FPS front.

On the load screens and certain angles in certain rooms when I'm not moving about, I get 60FPS, not surprising. However, when I start moving (especially in the entrance by the couches in the Dorms), and when moving about in Tartarus, the FPS drops to around 40FPS, to as low as 25FPS.

I've followed some advice from these threads:
Atlus games setting's HOW TO
Persona 3 FES tweaking?
persona games' FPS DROP
Persona 3 FES help
A small guide for people with LowEnd Computers
Persona 3

I've tried what they said but nothing seems to have worked so far.

Here are my system specs:
CPU: AMD Athlon64 x2 4600+, 2.41GHz
RAM: 2GB
GPU: nVidia 9800GT 512mb
OS: Windows XP ver. 2002, SP3

Here are my current settings with PCSX2:
Persona 3 FES ISO used
Version: PCSX2 0.9.6 (windows installer from main page)
Graphics: ZeroGS 0.97.1, with Interface Enabled, 800x600, x2 AA, nothing else checked
CD/DVD: P.E.Op.S. CDDVD 1.3.0, W2K/XP IOCTL scsi commands, reads one sector, only 'Try again on reading error' checked
Sound: SPU2-X 1.1.0, nearest interpolation, DirectSound, nothing checked
CPU: All check boxes checked, Limit checked, 0 on all Detailed Settings

SpeedHacks:
EE Sync Hack x2 Cycle Rate checked
Enabled IOP x2 Cycle Rate
Waitcycles Sync Hack checked

Advanced:
Chop/Zero, None, Flush to Zero and Denormals Are Zero all checked for EE and VU

Other things worth mentioning:
"DVCI: File cache was not hit" on DATA.CVM;1, BGM.CVM;1, and BTL.CVM;1

Is this just a case that my CPU is just not up to stuff to run the game consistently at 55-60FPS? Or is there something I haven't done or set properly? I've tried the x3 Cycle Rate in SpeedHacks and that didn't seem to do anything.

Any advice is welcome! ^.^

Sponsored links

#2
Try GSdx with NATIVE option enabled. and disable texture filtering
#3
I thinks fps drop because your cpu, try to overclock at.3ghz. Os vista can give your more fps in this game.
Notebook ASUS A43TA|CPU AMD Llano APU A6-3400m Triple core (1 core disable) OC to 2.6+Ghz|GPU CF|HD 6520 400Mhz/667Mhz iGPU|HD6650M OC 780Mhz/985Mhz dGPU|RAM 8GB DDR3 1333|Windows 7 Ultimate Sp.1 x64 bit.
>> Emulation speed differs for each game. There will be some you can run fast easily, but others will simply require more powerfull hardware <<.
#4
(03-17-2009, 09:43 AM)redlof Wrote: Try GSdx with NATIVE option enabled. and disable texture filtering

GSDx 890 SSE2 0.1.14: Tried your suggestion, but aside from the quality of the images/visuals, there was no real impact on FPS Sad It didn't get too much worse, but it definitely did not get any better. Thanks, though Sad

(03-17-2009, 09:57 AM)Register Wrote: I thinks fps drop because your cpu, try to overclock at.3ghz. Os vista can give your more fps in this game.

I'm trying to exhaust all available options before resorting to overclocking or--heaven forbid--purchasing new parts. @_@
#5
The game does some kinda stressing calculations on the VUs. Your settings are all fine, it's just that the CPU can't keep up with the VU stuff..
#6
I'm sorry to say that the only problem is your CPU, my E7200 at default speed (2.53ghz) is quite laggy.
Most of the time I can only get~50fps. But when I OCed him to 3.7ghz, everything when fine, now I can play it at ~70-90fps at most of the time (EXCEPT for when you encouter "silver enemies" in tatarus, trust me, I doubt you can get more than 10fps)
#7
So there really is no amount of tweaking that I can do? Just overclock or get a new CPU, that's it? Sad
#8
Your settings was optimal, you can not gain more fps except buy more strong cpu or overclock your cpu or you can get more fps with vu skip in option but this is not good choiche.
Notebook ASUS A43TA|CPU AMD Llano APU A6-3400m Triple core (1 core disable) OC to 2.6+Ghz|GPU CF|HD 6520 400Mhz/667Mhz iGPU|HD6650M OC 780Mhz/985Mhz dGPU|RAM 8GB DDR3 1333|Windows 7 Ultimate Sp.1 x64 bit.
>> Emulation speed differs for each game. There will be some you can run fast easily, but others will simply require more powerfull hardware <<.
#9
I have a 'AMD Athlon™ 64 X2 Dual Core Processor 5000+ (2 CPUs), ~2.6GHz' and I'm getting 60-45 FPS in the whole game, most of the time 60 though, only in the class with 10+ npcs it's gets down to 40ish.

First off, you really need Vista to run it on full speeds, second use XAudio 2, that might speed thinks up.
And just a tip, put your CPU on 'Limit' and then '60' in the first box, so it won't go awkwardly fast, you could also try putting AA off, might give you a few FPS more, but yeah, Vista is the biggest thing =)
#10
(03-17-2009, 09:43 AM)redlof Wrote: Try GSdx with NATIVE option enabled. and disable texture filtering

thank you u saved my life. For me it was all i needed to do and now everything is clear and perfect. Thank you




Users browsing this thread: 1 Guest(s)