Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Shining Force Neo and EXA
#1
Is there anything that can be done about the partner AI in that game? It runs really well otherwise, but the partner you have to help you in combat doesn't move... at all.... ever.
However will attack if something comes in range, but still not really helpful when you're on one side of the map and they're on the other.
Is there an already known fix for this? (I hope so I loved those games)
Reply

Sponsored links

#2
In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
(02-06-2016, 10:57 PM)jesalvein Wrote: In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.

Specs are in my signature now.
Using the most up-to-date version.
Only thing I've changed is the video plugin to OpenGL
Titled for the games I'm having the problem with.
CPU: I5-2300 @ 2.80GHz
RAM: 6 go
Gpu: GeForce GTX 750 Ti
Mobo: Acer Predator G6310
Reply
#4
Nothing you can do about it. That's just ***** programming of the game's AI system. Though personally I never had a problem with it in SF EXA.
Intel Core i5-4670K @ 3.40GHz | 16GB (2x8GB) DDR3-1866 G.SKILL Sniper Series
AMD Radeon R9 280 @ 3 GB | 120GB SSD | Windows 7 Ultimate x64 (SP1)
Reply
#5
Question is: Does the game behave the same on a real console, or not?
Reply
#6
(02-06-2016, 11:38 PM)rama Wrote: Question is: Does the game behave the same on a real console, or not?

No. It's been a long time, but I know the your partner AI is supposed to follow you, attack automatically when enemies are in range, use skills on their own, etc.
CPU: I5-2300 @ 2.80GHz
RAM: 6 go
Gpu: GeForce GTX 750 Ti
Mobo: Acer Predator G6310
Reply
#7
It's been a very long time, but I finished EXA on both ps2 and pcsx2, and I don't remember much difference between them.
Reply
#8
(02-06-2016, 11:51 PM)K.F Wrote: It's been a very long time, but I finished EXA on both ps2 and pcsx2, and I don't remember much difference between them.

Hopefully it's okay for me to link videos as examples, this isn't my youtube channel or anything, just a good example of how it's supposed to play:
https://www.youtube.com/watch?v=kVUPlyxn1h0 (starts at 6:52)
I've reached that point in the game already but instead of the archer chick following me, she never moves past the entrance on the PCSX2 version.
CPU: I5-2300 @ 2.80GHz
RAM: 6 go
Gpu: GeForce GTX 750 Ti
Mobo: Acer Predator G6310
Reply
#9
(02-07-2016, 12:06 AM)Victus Wrote: Hopefully it's okay for me to link videos as examples, this isn't my youtube channel or anything, just a good example of how it's supposed to play:
https://www.youtube.com/watch?v=kVUPlyxn1h0 (starts at 6:52)
I've reached that point in the game already but instead of the archer chick following me, she never moves past the entrance on the PCSX2 version.

That's how it behaves for me. They sometimes get stuck, and other times they function like normal, but that happened on the original PS2 too.

(Btw that video you linked is from PCSX2 footage. Note the texture glitches on the HP gauges, plus the fact that it's in HD).
Intel Core i5-4670K @ 3.40GHz | 16GB (2x8GB) DDR3-1866 G.SKILL Sniper Series
AMD Radeon R9 280 @ 3 GB | 120GB SSD | Windows 7 Ultimate x64 (SP1)
Reply
#10
(02-07-2016, 12:06 AM)Victus Wrote: I've reached that point in the game already but instead of the archer chick following me, she never moves past the entrance on the PCSX2 version.

Is that something that happens every single time in multiple places? If so, and you really haven't changed any default setting, then try an older build. If I'm not mistaken, I played it fine with 0.9.8 or something ancient, yo might not need to go that far back.

The game definitely was not that broken in the older builds. There was a bunch of changes in the EE side lately, so there is a small change that it is a regression.
Reply




Users browsing this thread: 1 Guest(s)