Thread Rating:
  • 1 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Should I be getting only 10-20 fps in Shadow of the Colossus with my specs?
I must be doing something wrong.

-Intel i7 920 2.66 Ghz processor
-6 GB ddr3 tri channel ram
-Radeon HD 5870 graphics card
-7200rpm 1TB caviar black wd hard drive
-Windows 7 Professional 64-bit

Everything is running at stock settings.

Here's some screenshots of my plugin settings:

It's 60 FPS while loading, but once the opening cinematic starts or when the game starts, it all slows down to a crawl, anywhere from 5-10 FPS at its worst.

Any help is appreciated.

Sponsored links

well, thats odd, my specs are lower than that, and i run games at full speed with no speed hacks, but i enable them anyways, just in case. but you should be able to run it with those specs

does it only happen with SOTC?
Kingdom Hearts runs at 40-60 fps, though it did hang once I finished the tutorial and got to the overworld.
Turn off all speed hacks and turn off Vsync.
Also try using the latest public beta (r1888) and a newer GSdx plugin.
See if that gives more FPS.
[Image: yunacopy.jpg]
Okay, I'll be back with an update in a minute after I do all that.
It's giving me about the same thing in terms of fps.
Ys Ark of Napishtim actually runs at full speed if I skip all the cutscenes. It's not exactly a visually impressive game though.
Download CPU-Z and check your CPU frequency while running PCSX2 to see if it's running at full speed.
[Image: yunacopy.jpg]

Well here's what I got while SoTC opening was running at less than 4 fps.
Shadow of Colussus generally runs slow, no? That's like one of the few games that runs slow on my system. Well, it's not slow, but it's not smooth either.
It's beyond slow though. It's practically standing still.

Users browsing this thread: 1 Guest(s)