Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Sign plugin DLL's?
#1
Will PCSX2 plugins ever get official signing for DLL's?

I can't seem to be able to use the DLL's anymore "because they came from another computer" and when i try to open PCSX2. It hangs at trying to enumerate available plugins.

This has been happening since a Windows 10 update and i can't find a way to disable this annoying behavior(Even by googling).
Reply

Sponsored links

#2
(05-27-2016, 01:23 AM)jbrianj Wrote: Will PCSX2 plugins ever get official signing for DLL's?

I can't seem to be able to use the DLL's anymore "because they came from another computer" and when i try to open PCSX2. It hangs at trying to enumerate available plugins.

This has been happening since a Windows 10 update and i can't find a way to disable this annoying behavior(Even by googling).

switching to a good OS would be a good start.

Dunno if the unsigned drivers enforcement option still exist in Windows 10, but you could give a try, though...
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
you can go on to the file properties and click "unblock" it's because you downloaded it from the web, you must have your security settings set to high somewhere to stop you reading them. I can't say I've come across that before with the emu and I'm using Windows 10.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#4
(05-27-2016, 06:13 AM)jesalvein Wrote: switching to a good OS would be a good start.

Dunno if the unsigned drivers enforcement option still exist in Windows 10, but you could give a try, though...

what wrong with windows 10? I have no issue with it and pcsx2 and the unsigned driver option exist still, one way to get at it is hold shift while clicking restart a menu will pop up with bunch of options
Reply
#5
(05-27-2016, 07:02 PM)tsunami2311 Wrote: what wrong with windows 10? I have no issue with it and pcsx2 and the unsigned driver option exist still, one way to get at it is hold shift while clicking restart a menu will pop up with bunch of options

I don't think it's blocked because of this. I also can't find a way to disable this behavior because there's literally no documentation available on the internet about this file blocking.
Reply
#6
(05-29-2016, 04:19 AM)jbrianj Wrote: I don't think it's blocked because of this. I also can't find a way to disable this behavior because there's literally no documentation available on the internet about this file blocking.

Did you try what I suggested?
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#7
delete this.
Reply
#8
I pretty much managed to solve the problem on my own.

I made a self-elevating powershell script that automatically unblocks all files within the pcsx2 folder.

http://s000.tinyupload.com/index.php?fil...7234311266

Put the file inside your pcsx2 directory.

For now you'll have to manually edit the path inside the  because i need to find a way to execute from directory(never used powershell)
It's all the way down to where it states:
"# Executes code here when admin". It'll be easy to see from there.

After that just right click and press "Run in Powershell"(Because by default it will edit the file, not run it)
Reply
#9
I have had ZERO issues running PCSX2 from my F: Emulators folder on Windows 10 without doing anything fancy other then just run it normally. But then again I do use the GIT builds and NOT the installed version
Reply
#10
(06-01-2016, 03:43 AM)Topken Wrote: I have had ZERO issues running PCSX2 from my F: Emulators folder on Windows 10 without doing anything fancy other then just run it normally. But then again I do use the GIT builds and NOT the installed version

I'm using the GIT builds aswell, i do somehow get issues when files are blocked. Some friend who also has the files blocked does somehow not get the issue with haning at "enumerating available plugins". It could be my antivirus(Avira Antivirus Pro) but i doubt it. It might also be some system configuration setting that causes this. Yet i do not know what it is (yet).
Reply




Users browsing this thread: 1 Guest(s)