Thread Rating:
  • 1 Vote(s) - 2 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Silent Hill: Origins audio stuttering and lag
#1
I am trying to run Silent Hill: Origins on PCSX2 0.9.7 (r3878) but am getting really bad audio stuttering during cinematics. The game runs fine until I get inside the burning house when it becomes almost unplayably slow. What are the best settings to fix these problems and run Silent Hill: Origins properly? I know it can be run very well because of this video: http://www.youtube.com/watch?v=SdPypMihuH0 . Here are my system specs:

Intel Core 2 Quad @ 3.00 GHz
HD Radeon 4870 1GB
6GB DDR3 RAM
Windows 7 Professional 64-bit

Thanks for any help.
Reply

Sponsored links

#2
Keep in mind when someone records with the built in pcsx2 recorder it will record and adjust it as if it where running at full speed.

Try setting GSDX to software mode inside the house, it may make it a playable speed until you leave the house.
Reply
#3
Yes, using F12 to record is very slow, but when the video is played back, it runs perfectly, like if it was running on real hardware. A good rule of thumb is, when recording, the lower the resolution (such as 320x240, 640x480), you will be able to record at acceptable speeds.
Custom Desktop
CPU: Ivy Bridge Core i5 3570 3.4 GHz (3.8 GHz w/ Turbo Boost)
CPU Instructions: MMX, SSE1, SSE2, SSE3, SSSE3, SSE4.1,
SSE4.2, EIST, iAMT2, Trusted Execution Technology (TXT)
OS: Windows 7 Professional 64-bit
RAM: 8192MB DDR3 SDRAM PC3-10600 1333
HDD: 1 TB Western Digital HDD
Video: MSI GeForce GTX 660 2 GB GDDR5
Audio: Realtek 5.1 HD Audio
Reply
#4
Thanks for the responses. What kind of performance do you guys get in the burning house?
Reply
#5
~30fps in software and ~80fps in hardware, software is needed for later tho... unless you like to kill the game ambience that is...
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#6
(11-01-2010, 05:13 AM)Shadow Lady Wrote: ~30fps in software and ~80fps in hardware, software is needed for later tho... unless you like to kill the game ambience that is...

I have it running in Dx10 software mode and get roughly 30 fps too. It seems to run really choppy though. Is the game playable afterwards though? Also, is anyone else having this problem with the audio skipping in the cinematics? Is there a fix? Thanks.
Reply
#7
(11-01-2010, 05:30 AM)Vdaxzter Wrote:
(11-01-2010, 05:13 AM)Shadow Lady Wrote: ~30fps in software and ~80fps in hardware, software is needed for later tho... unless you like to kill the game ambience that is...

I have it running in Dx10 software mode and get roughly 30 fps too. It seems to run really choppy though. Is the game playable afterwards though? Also, is anyone else having this problem with the audio skipping in the cinematics? Is there a fix? Thanks.

Lot's of games, including popular ones have frequent video problems. Software mode fixes most of them, but it's slow for most people. You probably need a processor that clocks over 4ghz per core to run at full speed.

It is most likely that you will lag during heavy scenes, such as the fiery building or the cutscenes when the world changes.

Other than that, when it becomes unplayable, simply swap to software mode and toy around with frameskipping under GS settings.

You activate it with shift+f4.

Keep messing around with it until it doesn't flicker, and your FPS should jump from low 30's to 55 but jumpy. (You should only have to do this when hardware mode fails you, like the fire part.)
Reply
#8
(11-01-2010, 05:38 AM)Chase_Payne Wrote:
(11-01-2010, 05:30 AM)Vdaxzter Wrote: I have it running in Dx10 software mode and get roughly 30 fps too. It seems to run really choppy though. Is the game playable afterwards though? Also, is anyone else having this problem with the audio skipping in the cinematics? Is there a fix? Thanks.

Lot's of games, including popular ones have frequent video problems. Software mode fixes most of them, but it's slow for most people. You probably need a processor that clocks over 4ghz per core to run at full speed.

It is most likely that you will lag during heavy scenes, such as the fiery building or the cutscenes when the world changes.

Other than that, when it becomes unplayable, simply swap to software mode and toy around with frameskipping under GS settings.

You activate it with shift+f4.

Keep messing around with it until it doesn't flicker, and your FPS should jump from low 30's to 55 but jumpy. (You should only have to do this when hardware mode fails you, like the fire part.)

Thanks for the advice about hardware mode. In Dx10 hardware mode, performance in the burning house is great (no lag at all). The issue with the cinematics doesn't happen when the actual game's visuals are rendered. There is no skipping or stuttering with the audio when the in-game graphics are displayed. The audio stuttering happens with the intro cinematic. Here is a video of the cinematic that stutters: http://www.youtube.com/watch?v=9wCxEcJIhsY . If you watch from about 1:30 to 4:06, that is when the audio stutters. Are there any settings with the audio plug-in that would fix that issue?

On an unrelated note, is anti-aliasing possible in hardware mode?

Thanks.

Reply
#9
I don't get stutering in videos here with the default settings (no speedhacks and spu2-x with synchronizing timestretching as sound plugin being the defaults).
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#10
(11-01-2010, 06:05 AM)Vdaxzter Wrote:
(11-01-2010, 05:38 AM)Chase_Payne Wrote: Lot's of games, including popular ones have frequent video problems. Software mode fixes most of them, but it's slow for most people. You probably need a processor that clocks over 4ghz per core to run at full speed.

It is most likely that you will lag during heavy scenes, such as the fiery building or the cutscenes when the world changes.

Other than that, when it becomes unplayable, simply swap to software mode and toy around with frameskipping under GS settings.

You activate it with shift+f4.

Keep messing around with it until it doesn't flicker, and your FPS should jump from low 30's to 55 but jumpy. (You should only have to do this when hardware mode fails you, like the fire part.)

Thanks for the advice about hardware mode. In Dx10 hardware mode, performance in the burning house is great (no lag at all). The issue with the cinematics doesn't happen when the actual game's visuals are rendered. There is no skipping or stuttering with the audio when the in-game graphics are displayed. The audio stuttering happens with the intro cinematic. Here is a video of the cinematic that stutters: http://www.youtube.com/watch?v=9wCxEcJIhsY . If you watch from about 1:30 to 4:06, that is when the audio stutters. Are there any settings with the audio plug-in that would fix that issue?

On an unrelated note, is anti-aliasing possible in hardware mode?

Thanks.
Anti aliasing is possible, and should show up.
[Image: capturekp.png]

Now one thing to say, this "HACKS" tab did not appear until I completely deleted the directory of pcsx2, and removed UAC from my computer and ran it under administrator after installed.

I then deleted the INIS in my documents before the first execution, and it showed.

The saves are store in your documents, but it's safer to just rename the folder altogether, then delete it.


If it runs at max in hardware mode, then you will play the game just fine. But FMV's will always be glitchy in hardware mode. It's something you have to get used to, it even affects sound too.

Sound tends to skip if you have any speed hacks enabled also.



Reply




Users browsing this thread: 1 Guest(s)