Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Siren 2 pal version 2 issues im having.....
#1
I found and bought a pal version of siren 2 at a indoor mall in my city from a seller selling all kinds of import games and consoles and I loaded it with the latest pcsx2 emulator 0.96 and it runs smooth so far but 2 issues:

The game has stragiht verticle lines across the screen like 7 of them. Any one a fix for this?

Also after the first cutscene when the little boy goes downstairs to find his dad murdered on the floor it go to the typical mission accomplished screen then after that the screen stays blank. Anyone know whats going on here? Thanks.
Reply

Sponsored links

#2
About vertical lines: Check native in GSdx or try finding a custom resolution that doesn't have lines (although it could be this way with all custom resolutions). Try 1270x1270

The second issue sounds like a soft crash,disable all speed hacks see if that helps. If not,try changing some advanced options in PCSX2 like changing the Round Mode.
Also give the latest beta a try if you're not already using it
[Image: newsig.jpg]
Reply
#3
(07-29-2009, 11:14 PM)Bositman Wrote: About vertical lines: Check native in GSdx or try finding a custom resolution that doesn't have lines (although it could be this way with all custom resolutions). Try 1270x1270

The second issue sounds like a soft crash,disable all speed hacks see if that helps. If not,try changing some advanced options in PCSX2 like changing the Round Mode.
Also give the latest beta a try if you're not already using it

OK im using the gsdx sse2 plugin and when i go to configure it doesnt have the option to type in a custom resolution!

Now is this file name the latest beta version "PCSX2_0.9.6_setup.msi" ?

THanks.
Reply
#4
1)It does,in the D3D internal res boxes.
2)No,that's the 0.9.6 release. Beta is found here: http://pcsx2.net/downloads.php?p=publicbeta
[Image: newsig.jpg]
Reply
#5
(07-29-2009, 11:50 PM)Bositman Wrote: 1)It does,in the D3D internal res boxes.
2)No,that's the 0.9.6 release. Beta is found here: http://pcsx2.net/downloads.php?p=publicbeta

Well I created a save point right before the cutscene of my murdered dad before the blank screen issue and I changed those EE options one by one in the advanced area of emualtor and still produces the blank screen.

The beta version doesnt even run the game.
Reply
#6
well,maybe it's not reading the DVD good enough,try making an ISO from the game using MagicISO,and then using LinuzzISO try running the game from the hard drive..if that doesn't work,and you have the iso,try to play the NTSC version (you can "transform" your PAL into ntsc with a programme called pal2ntsc fix...)


Attached Files
.rar   ps2_pal2ntsc_yfix.rar (Size: 350,86 KB / Downloads: 72)
Reply
#7
(07-30-2009, 01:26 AM)korisnik2007a Wrote: well,maybe it's not reading the DVD good enough,try making an ISO from the game using MagicISO,and then using LinuzzISO try running the game from the hard drive..if that doesn't work,and you have the iso,try to play the NTSC version (you can "transform" your PAL into ntsc with a programme called pal2ntsc fix...)

Ok so I patched the iso with that P/N selctor option and then I laoded the iso like normal and a screen with green text xame up asking to select from like 3 options so I booted the iso as "pal to ntsc with y-fix" option and it runs like before but still has those straight verticle lines across the screen like 7 of them with a couple of inches between them. And after the first mission cutscene it goes to mission accomlished words then goes to another ingame menu showing you like the current day or something just like in siren 1, then once that goes away nothing else seems to happen just a blank screen.
Reply
#8
you shoudln't have done that...Usually what you do is backup the ISO,and then patch it to NTSC only,and it should work...Sorry for not telling you earlier...Then again,would you be kind enough to tell me your specifications???
Reply
#9
(07-30-2009, 01:48 AM)korisnik2007a Wrote: you shoudln't have done that...Usually what you do is backup the ISO,and then patch it to NTSC only,and it should work...Sorry for not telling you earlier...Then again,would you be kind enough to tell me your specifications???

So you mean when that green text screen comes up dont choose the option to load the iso with "pal to ntsc+ y-fix"? Your saying choose the one to load it "pal to ntsc"?

My pc specs are its a gaming pc btw:

amd phenom 2 x4 920 2.8ghz
geforce gtx 260 pci express
4 gigs ddr2 ram
vista ultimate sp1
Reply
#10
no,no...when runing the pal2ntsc yfix,you don't check the pal or ntsc selector at all..So,what I mean is when you do it properly,you can only play NTSC version..Try passing that part with ZeroGS...
Reply




Users browsing this thread: 1 Guest(s)