Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
"Siren (USA)" Link Navigator/Stage Select bug (text/icon not showing)
#1
Hi, I'm currently playing  Siren (USA), and in the link navigator (or in stage select) there should be some icons. At least that's what the in-game help says:

   

But when I'm browsing the grid, I can't find any icon, and I'm 100% a lot of them should be showing. In the following picture I'm hovering over a half blue/half light blue box where such text (or icon, I don't know for sure) should be displaying. Notice how the box is empty.

   

This lack of text renders this game virtually unplayable without a guide, since you positively need these lacking texts/icons to know wich stage to play next, in order to find items and unblocking the new chapters of the game. 

My graphic settings are as follows:

   

If someone can help me find a workaround with this issue I'll be extremely grateful.

Finally, there's a known problem with this game, theres a problem with the fog (it looks solid). The workaround for this is to put the renderer in software, so this game is not without it's emulating problems.
Reply

Sponsored links

#2
In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
(12-10-2016, 08:45 AM)jesalvein Wrote: In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.

Hi jesalvein, thankyou for the reply.

My hardware consists of a I7 6700K (same as you), 16 gb corsair, windows 10. I don't have a dedicated gpu yet.
I'm using PCSX2 1.4.0.
My only non default setting is Direct3D9 (software) intead of Direct3D9 (hardware) because of the fog issue "Siren (USA)" has when being emulated.
The only game I had problems with is this one, "Siren (USA)"
I'm not playing this game in ISO per se. But with a zipped file made with 7zip (gz). The file's name is Siren (USA).iso.gz

Sorry foir not posting all of the above on the first time.
Reply
#4
To fix the issue with the fog use the 1.5.0 latest git versions , Render OpenGL , Enable Hw hacks and activate "Disable Depth Emulation"
CPU: I3-4160 3.6GHZ
Motherboard: Asrock B85M - DGS
RAM: Hyper X Savage 2x8GB 1.6GHZ cl9
GPU: Asus AMD Radeon R7 360 OC 2GB GDDR5
OS: Windows 7 Ultimate SP1 64bit
Reply
#5
(12-10-2016, 03:45 PM)lightningterror Wrote: To fix the issue with the fog use the 1.5.0 latest git versions , Render OpenGL , Enable Hw hacks and activate "Disable Depth Emulation"

Hi lightningterror, I didn't know what git was previous to your post, I'm downloading a git pcsx2 version right now. Regardles, the main problem still is the missing text/icons on the menu. I'll be lurking in case someone knows about a way to fix it... The main proble here is that Siren is not the most popular game out there, so there will be very few persons interested in fixing this... The mere fact that I couldn't find about this issue online speaks by itself.

Thanks.
Reply




Users browsing this thread: 1 Guest(s)