Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Slow] Armored Core 3
#1
Hello everyone

I have detected another threat about AC3, but that one is aleady closed.

So I open another one! I hope I didn't miss another one Tongue2

The problem is: EE and GS are at 40-60% but AC3 only runs at 40~ fps, sometimes 60fps.

There are videos from a very old PCSX2, 0.9.7.3*** in which the game runs perfect, maybe in newer SVN AC3 slows the emulator down?

My two HW-parts:
Intel Q9550@3.06 GHz
HD6870 2GB
OS: Windows 7 64x

pcsx2-5174-windows-x86
-- Configuration --
Emulator Settings:
EE/IOP: default
VUs: default
GS: default
GS window: default
Speedhacks:
Quote:    

I tried w/ and w/o

Plugins and GSDx:
Quote:    

I tried SW & HW Native

I don't know why, but SPU2-X:
Quote:    
Reply

Sponsored links

#2
When EE/GS/VU% are low, most likely GPU is stopping you from getting full speed. You can try "allow 8 bit textures" in GSdx option, as it's often what AMD gpu's need to get any decent speed also try to decrease the internal res or using DX9(usually it's slower, but there are exceptions), and if nothing of that work, then try older GSdx version(the one from 0.9.8 - current official release for example), as in some games new GSdx can be awfully laggy even at the fastest gpu's.
Reply
#3
(05-04-2012, 12:54 AM)miseru99 Wrote: When EE/GS/VU% are low, most likely GPU is stopping you from getting full speed. You can try "allow 8 bit textures" in GSdx option, as it's often what AMD gpu's need to get any decent speed also try to decrease the internal res or using DX9(usually it's slower, but there are exceptions), and if nothing of that work, then try older GSdx version(the one from 0.9.8 - current official release for example), as in some games new GSdx can be awfully laggy even at the fastest gpu's.

Hello,

I tried PCSX0.9.8 and PCSX0.9.7 public beta, all with the same settings, some variations and also the current SVN I use + the GSDx plugin from 0.9.7+0.9.8. (of course also with Your recommendation)

Somewhat all the same result... Maybe HD6870 is just not compatible in some way?

GS was not only around 40-60%, it was at 78% one time, but only for a very short duration, than around 60% all the time, jumping up and down.

Man... I really want to play it on the emulator Sad I'm going to try some more GSDx plugins



---- EDIT ----

OKAY! Cool... I got to work with 60fps, in a AC battle for now, gonna do further testing, but it runs better now, there are some noticable graphic glitches, but not really worth to mention.

This is Config:
   

This is WITHOUT any speedhack!! But I tried using the same GSDx plugin for the newer SVN, but I don't get the same results for some reason Sad

--- EDIT 2 ---

The first mission I tried --> low fps again Sad
Reply
#4
Tried reducing internal res? Couse I see you having x3 all the time and this game from what I read is really gpu intensive, try x2 or even native in GSdx in the moments you have slowdown and see if it does any change, don't forget to change "allow 8 bit textures" too "on/off", to actually see if it does improve your fps or the opposite, couse that option althrough often needed for decent speed on radeons, can as well cause a major slowdown depending on a game(that's why it's surely not an option to check and forget:f).

Oh and if nothing helps, even decreasing internal res to native will not speedup the game, keep in mind that movies on youtube aren't really an accurate way to check how demanding game is. People can record even at 1fps, and get a full speed in the movie. Generally nothing's wrong with your gpu, althrough nvidia can be faster in emulation at times(I shamefully say that as a radeon owner myself soo no fanboyism included), some games just like to show off how demanding they can beTongue, AC3 is probably one of them.
Reply
#5
(05-04-2012, 11:24 AM)miseru99 Wrote: I shamefully say that as a radeon owner myself

you are not the only one...Tongue

*sob
Reply
#6
(05-04-2012, 11:24 AM)miseru99 Wrote: Tried reducing internal res? Couse I see you having x3 all the time and this game from what I read is really gpu intensive, try x2 or even native in GSdx in the moments you have slowdown and see if it does any change, don't forget to change "allow 8 bit textures" too "on/off", to actually see if it does improve your fps or the opposite, couse that option althrough often needed for decent speed on radeons, can as well cause a major slowdown depending on a game(that's why it's surely not an option to check and forget:f).

Oh and if nothing helps, even decreasing internal res to native will not speedup the game, keep in mind that movies on youtube aren't really an accurate way to check how demanding game is. People can record even at 1fps, and get a full speed in the movie. Generally nothing's wrong with your gpu, althrough nvidia can be faster in emulation at times(I shamefully say that as a radeon owner myself soo no fanboyism included), some games just like to show off how demanding they can beTongue, AC3 is probably one of them.

Already tried with Native, 8-bit on/off Sad 8-bit seems to improve it a bit, but not by far... I'm kinda lost, maybe there is just no way to play it at 60fps, but in: http://forums.pcsx2.net/Thread-another-A...e-3-thread -- See Post #9 and #11, the user seems to have fixed the "slow" problem, but I just don't understand HOW, I can't really take much information from "second post from the bottom by IVXXX."

I know what you mean with ATI/Nvidia... I don't know why I bought another Radeon... Tongue2 Maybe I don't want to give up hope
Reply
#7
The person in that old thread had similary powerfull gpu(well from pcsx2 perspective at leastTongue), and what helped him was I guess this post from ngemu forums which has basically config the person used on some old pcsx2 version which seems you already tried. Dunno what else of advice to give you, sometimes using skipdraw hack in GSdx hardware hacks can speed the game up if it's slowed down by some effect, but it might as well delete all eyecandy, postprocessing or just glitch the graphics.

The only other thing which comes to my mind would be that your gpu seeing low gpu usage when being limited by memory bandwidth doesn't jump into higher performance mode automatically as some radeons around yours tend to behave strange like that(you can check it for example with GPUZ). If that IS the case, you could install a program like "MSI Afterburner" or "AMD GPU Clock Tool" and force your gpu to use it's normal - full - power while playing on pcsx2 if it's sitting in some power saving mode, or at least try to set windows power profile to high performance, hoping it'll force it too.
Well, good luck.
Reply
#8
I'm sorry, I don't quite understand how to check that, I have GPUZ, but where can I check the memory bandwith problem? For now I have disabled any energy control by windows for my GPU.

Screenshot from GPUZ, if you can tell me if there is something wrong:
   

btw. I can somewhat play AC3 with the old SVN, I can play AC Arena and a few missions without problems, 60fps constant, but in many missions the FPS drops down to 50fps and sometime even 40fps for now, I think if there is a mission with more than 1 other AC than me, then FPS will drop even more.
Reply
#9
(05-04-2012, 08:30 PM)Streidominating Wrote: I'm sorry, I don't quite understand how to check that, I have GPUZ, but where can I check the memory bandwith problem?

the "sensors" tab
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#10
I only ment that for some people(well at least one person wrote about problem like that, unless I mixed two different things in my memory thinking about thatTongue) when they run pcsx2, their radeon doesn't turn on all it's power, that doesn't seem to be the case here.

The game is just too demanding, the model thingy is actually fairy common problem, in loads of games certain models, even awfully simple ones can multiply requirements for gpu to be able to handle it;]. Like for example gears in xenosaga or any char models in budokai tenkaichi series, guess there is just too many of them in AC3 for that radeon to handle(knowing life, same priced nvidia would be good enough;f). Sometimes software works faster in such cases, but that usually needs stronger cpu and as you already tried it, guess it's wasn't faster for you.

There is one more option to speedup the game, but with how it works I personally never recommend it, it's most of the time for desperate people only @_@... frame skipping in config>emulation settings>GS this will surely decrease the load on gpu&gs thread, increasing the speed, but in the same time at best turning the gameplay choppy, at worst, creating a glitch-land. You could set it only to work during turbo mode and set turbo as 100% to activate/deactivate frame skip with the press of TAB key. Heh, but really if a game needs frame skipping to work at full speed and it's an action game where both speed and smoothness matter alot, it's better to just give up running it through emulator.;P
Reply




Users browsing this thread: 1 Guest(s)