Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Slow FPS on good computer. Why?
#1
Hello everyone.
Every time I try to play a game with Pcsx2, my fps is slow (it even goes down to 15).
Here are the specs of my laptop:

Nvidia Geforce GT 630M
Intel Core i7-3630QM 2.40 Ghz
Ram: 8 GB

Here are my settings on PCSX2:

[Image: 3vvLb1R.jpg]
Reply

Sponsored links

#2
1 - it's a good computer for pc gaming, but it's a bit weak for pcsx2.
2 - better use Dx10/11 hardware mode instead of dx9
3 - which game(s) are you trying to play ? are you playing from iso or DVD ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
Set power management plan to high performance.
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply
#4
Thank you guys. Setting high priority and Dx11 helped me reaching 26fps, but the game is still unplayable.
I'm talking about the .iso of "The Getaway". Some happens with "Shadow of the Colossus".
Isn't there anything else I can do?
Reply
#5
about the getaway -> make sure your windows power plan is set to high perfromance and enable recommended speedhacks. But I think you'll have to play it on your PS2 to enjoy it correctly anyways.
about shadow of the colossus -> this game is really demanding, but luckily reacts really well to vu cycle stealing speedhack. that should make it playable (no full speed, but playable)
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#6
(03-28-2014, 04:55 PM)jesalvein Wrote: about the getaway -> make sure your windows power plan is set to high perfromance and enable recommended speedhacks. But I think you'll have to play it on your PS2 to enjoy it correctly anyways.
about shadow of the colossus -> this game is really demanding, but luckily reacts really well to vu cycle stealing speedhack. that should make it playable (no full speed, but playable)

Ok, used speedhacks. The game is now fast. The only problem I'm having is with cutscenes (people disappearing random...quite funny!). Thank you.
Reply
#7
(03-28-2014, 05:05 PM)Askaron Wrote: Ok, used speedhacks. The game is now fast. The only problem I'm having is with cutscenes (people disappearing random...quite funny!). Thank you.

You can try to set clamping mode (Vu's and EE) from Normal to Complete and Extra+Preserve Sign ... Also you tried Software mode (F9) during cutscene?
Reply




Users browsing this thread: 1 Guest(s)