Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Slow FPS rate in The legend of Spyro series
Help! The Legend of Spyro Dawn of the Dragon boots up fine at the beginning but once it goes to the game after the menu, the FPS rate cuts by half from 50 to 25 plus the audio is laggy and does not play well or play at all. Same thing happens for The Legend of Spyro A New Beginning and The Eternal Night and has colour distortions and does not display the menu. Help!
Here are my specs:
OS: Windows 7 Home Premium 32-bit
Processor: Intel core 2 Quad Q9300 @ 2.50 GHz
Ram: 4Gb Dual Channel DDR3 @ 533 MHz
GPU: Nvidia Geforce GT220

Sponsored links

Your graphics card is really crappy, you better check 'Native' in GSdx but that won't help much either. You can also take screenshots of your settings by using the button at the bottom left corner of each window, much easier than taking photos of your monitor Tongue
[Image: newsig.jpg]
I already checked the native checkbox before you told me. Is there something else i can do? I'm desperate.Sad Oh thx for telling me how to take pictures of my settings the easier way.Smile What gpu would you recommend?
GTS 250 ... is what I'd like to say but it uses about 150W max power draw.

Get a 5750 if your PSU can support it, it only uses 86W at full load.
Try speedhacks (found in the emulation settings menu), particularily EE cycle rate hack (2x) and vu cycle stealing ("slight" should be ok for starters), and check the mVU Flag hack. Enable INTC Spin Detection too, and see if your game runs better then.

You don't ALWAYS need to immediately upgrade your PC when you can't run some game in PCSX2 you know... Tongue
I wish to give same advice as yours but his vgacard isnt really enought power for demanding games and got bottleneck with his cpu too even with native res being used.
Notebook ASUS A43TA|CPU AMD Llano APU A6-3400m Triple core (1 core disable) OC to 2.6+Ghz|GPU CF|HD 6520 400Mhz/667Mhz iGPU|HD6650M OC 780Mhz/985Mhz dGPU|RAM 8GB DDR3 1333|Windows 7 Ultimate Sp.1 x64 bit.
>> Emulation speed differs for each game. There will be some you can run fast easily, but others will simply require more powerfull hardware <<.
Hey Thx Finzy for the help. I finally get to play The Legend of Spyro at a faster rate.Biggrin
Yes i have the same problem.In the e.n. menu doesnt apear but i made it somehow to new game.Loading have bugged colors but in first cutscene fps is 50-60 and when it enters in game colors are completly bugged and at low fps and at dotd i have low fps rate 8,9-15 and some stranges lights over my screen.
Windows 7 ultimate 64 bit
AMD ATHLON 64 3500+
Geforce 8400 gs overclocked
I dont know how it can be to my computer,i play skyrim at medium settings and 3-4 years old game is lagging.I think it is a matter of program not computer.I have enabled speed hacks too.I also have san andreas mp. for pc and play evrything on high but if i download it for ps2 my fps will be 10.Sry for my bad english
kapul4 don't blame it on the game, Emulators are ALWAYS very CPU and sometimes GPU Intensive and the minimal recommended CPU Specs for most games is a Quad Core 3 GHz Smile your CPU + Graphic Card are quite old and also very slow to be able to play about 95% of the games through PCSX2. Also never compare PC Games with Emulated Games. Though with most Emulators there are exceptions ofcourse. F.e. SNES, Gameboy Smile

Users browsing this thread: 1 Guest(s)