Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Slow motion with more than recommended FPS
#1
I am attempting to play through Shadow of the Colossus on pcsx2. I say attempting because I am encountering a host of problems that i hope you may be able to help me with.

First off, I am running a stable 40-50+ fps (the game window says this is around 150% what is needed, while recently I recall 60 fps being the recommended fps). I am running a Core2Extreme QX6700 3.2ghz, so I am fairly certain this is not my problem, although it is a bit dated, as is my 8800 Ultra. CPU-Z

Another problem is that what seems like every time I play, the screen gets brighter. The title screen has literally become a white screen with the title across it and the choice to load a game.

And the problem that bugs me most is the fact that while two references state extremely playable fps (I use fraps as well as the readout in the title bar), the ingame refresh rate is clearly not up to par. I swear its refreshing twice a second, but more likely 10-20. I simply cannot play like this. My Graphics settings in PCSX2

The reason i don't just buy another PS2 (my current one's disc drive is broken) is that I have grown accustomed to the high resolutions I can play the games at. SoC looks simply gorgeous.

Hopefully someone can provide some insight to my problems.
Reply

Sponsored links

#2
Do you have speedhacks enabled? This game detects the "cpu load" of our virtual ps2, and speedhacks would cause it to think it's at full load.
This in turn makes the game enable its frameskip mechanism, in various degrees of suck.. Tongue2

The white screen is a blend effect that's hard to do in hardware rendering, try opening your gsdx.ini and add these 2 lines:
pixoff_x=-8
pixoff_y=-8
Reply
#3
Oh lord, the changes i made to the ini made it worse.
And the slow motion wasn't fixed by turning off speedhacks.
Reply
#4
An example of how overwhelmingly bright the game is.
Reply
#5
What's your D3D interal resolution in your GSDX settings set to?
http://www.twitch.tv/krazytrumpeter05
Want to stream your games? Let me know and I can help you get set up with Open Broadcaster Software.
Reply
#6
(10-02-2009, 05:58 AM)KrazyTrumpeter05 Wrote: What's your D3D interal resolution in your GSDX settings set to?
I provided a screenshot of my Graphical settings in the original post; the D3D internal resolution is set to my monitor's native res, 1680x1050
Reply
#7
Ah, sorry, I must have missed that.

Well, the issue of the overbright screen is typicall solved by upping your internal resolution. You set it to well over what is normally required(I leave my at 1024x1024 and that practically eliminates the problem) so I'm not sure why the issue persists. Hrm...I'll play around with some things and see if I can reproduce the issue.

Actually, wait, what revision of the emulator and GSDX are you using?
http://www.twitch.tv/krazytrumpeter05
Want to stream your games? Let me know and I can help you get set up with Open Broadcaster Software.
Reply
#8
The first time I played it was fine. The second it was more noticeable, and now it is unbearable. I am also starting to suspect this is part of my slow-motion troubles as well, as my speed was fine first time, worse second and etc.
Reply
#9
(10-02-2009, 06:04 AM)KrazyTrumpeter05 Wrote: Actually, wait, what revision of the emulator and GSDX are you using?
http://www.twitch.tv/krazytrumpeter05
Want to stream your games? Let me know and I can help you get set up with Open Broadcaster Software.
Reply
#10
I'm using 0.9.6 and GSdx 890 (MSVC 15.00, SSSE3) 0.1.14

Not sure if that's what you wanted.
Reply




Users browsing this thread: 1 Guest(s)