Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Slow on Champions
#1
I'm trying to run Champions of Norrath: Return to Arms on Windows 7 Ultimate 64-bit on a pretty decent gaming desktop (dx diag posted) and it's runs kinda bad. It seems I have to run in "software" mode to avoid screen glitching, and other games run a little smoother but not by much. They certainly don't run how I think they should. I'm pretty new to this kind of emulation and I'm running 1.2.1 PSX2 on mostly default settings. What do I need to do to get most games to run correctly?


Attached Files
.txt   DxDiag.txt (Size: 25,55 KB / Downloads: 76)
Reply

Sponsored links

#2
While using software mode, set extra rendering threads to something around 3-4 to use your processors full potential. Also, make sure to use the mtvu hack. If it still slows down, you should overclock your processor a little high.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#3
What's the mtvu hack? Where do I go to enable it? Also, I had 10 extra rendering threads already.
Reply
#4
No, having more extra rendering thread leads to diminishing returns. Set it to something like 3 and you can find the mtvu hack in speedhacks section settings.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#5
I set up just like you said and Im still having the same issue. Im seeing a message that keeps saying out of memory. I find it hard to believe a PS2 game uses that much memory and its only set to 3x Native Resolution. Is that maybe the issue? For some reason is PSX2 not using all my RAM? If so, how do I fix that?
Reply
#6
You need ntcore 4gb patch for this game
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#7
Run the 4gb patch on pcsx2.exe and set the emulator to 3-4 threads+ Turn off widescreen hack+zoom in all the way using the right stick in game. Only things that will help speed the game up. I get slowdowns on my i5 3570k oced to 4ghz so even if you have the beefiest of computers you are still going to get massive slowdowns with the Snowblind engine games like this. Just the way it is right now. The more stuff that is rendered the heavier the game is in the case of these games. So try to keep the camera as zoomed in as possible and turn off widescreen for these games.
Reply
#8
I got the patch, but i can't apply it. I keep getting an error saying couldn't open executable file when i try the 4gb patch on "pcsx2-r5875.exe." What am I doing wrong?
Reply
#9
Right click on the pcsx2 exe and select properties.

Check if it's read only, and if it is, make it not.
[Image: ov4]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#10
I guess pcsx2 is still running.
Check your tasklist or execute taskkill /F IM pcsx2-r5875.exe
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply




Users browsing this thread: 1 Guest(s)