Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Slow, out-of-sync sound (Tales of Symphonia [J] cutscenes)
#1
Tales of Symphonia runs at 60 FPS just fine (much higher without frame limiting) without speed hacks aside from MTVU, so I can't imagine this is a hardware issue, but during cutscenes, the audio skips and becomes out of sync. This is from a backup of the disc (iso), so it couldn't be a disc loading problem. When I increase/remove the frame limit, the fps jumps to very high levels, but the audio still stutters, despite increasing to twice the speed. It doesn't make any logical sense to me why the audio would stutter (it only happens during cutscenes, by the way; normal gameplay is perfect).

Any ideas on how I could fix this/it could be an error on my end, or should I submit a bug report?
Reply

Sponsored links

#2
Any speed hacks on? If yes, try disabling them all
[Image: newsig.jpg]
Reply
#3
I don't believe there were any except MTVU. I can check again.

EDIT: Yeah, no speedhacks at all on (not even MTVU) and the problem still occurs. Can speed up cutscene playback to 120 FPS with Turbo, but audio stuttering still occurs exactly the same except half as long per instance, etc. even at double speed.
Reply
#4
I've read on a thread here for another game, that when the audio is out of sync you could use Skipdraw hack and put it to 2 or 3. Not sure if this will help for this game aswell, but you can always try it out.
Reply
#5
Problems still occur no matter what. Skipdraw has no effect here, as it is the FMVs that skip, not 3D rendered scenes. My guess is that the audio plugin doesn't like it for whatever reason (I've tried DirectSound, XAudio, etc. with no luck).

This occurs without regard to CPU or GPU usage, and cutscenes run at over 200 FPS without frame limiting, so I am almost 100% sure that the audio plugin is at fault.

By the way, I have ripped the video from the disc and it plays flawlessly in other media players once converted to another format.
Reply
#6
It might be an SPU2-X bug then...
[Image: newsig.jpg]
Reply
#7
Neither sound plugin correctly emulates the sound, but both have different issues with the same audio. I will post a bug report then.
Reply
#8
Try setting it to async mode instead of timestrech and see if that helps if its already set that way try setting to to timestrech instead of async.
Reply




Users browsing this thread: 1 Guest(s)