Thread Rating:
  • 1 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Slow when running on battery,
#1
This may sound stupid but for some reason when my laptop is running on battery life the emulator is all too slow, but works just fine when the charger is plugged in. I've tried to put it on high performance and setting the advaced battery settings to exactly the same for both when it's running on battery and when it's plugged in, but to no awail.
I'm using Vista if that helps.
Reply

Sponsored links

#2
HAha, as this thread was opening for me I was thinking "Heh... I wonder if his computer's just setting itself to 'Power SaVer'"

Anyway, on to the problem. That does sound weird, I'Ve been using laptops since high school, and I can't really say I'Ve encountered something like that. Try opening up your control panel->processes-> then shift the emulator process's priority to "highest". Short of that I'm drawing a blank (though that idea is a good one, and came to me whilst I was writing, coincidentally)

Good Luck Smile
Reply
#3
I've already tried that, but thanks anyway!
Reply
#4
It won't work properly on battery.
[Image: newsig.jpg]
Reply
#5
it may not be windows' fault. some laptops downclock the CPU to save power(can be turned off in the BIOS) when they are on batteries
Reply
#6
Really? then how can i turn that off?
I'm not experienced with Bios related stuff.
Reply
#7
I can't really help you with that because I have no idea what options do you have in the BIOS, but if you'd go ask at the official forum of your manufacturer than you'd be better off, because there will be a high chance that it has already been asked, or that others have the same model as you and can navigate you through the menus if there really is a function to turn off.

My dads old Fujitsu Siemens lappy does this too, but you can't turn it off on it.

If that's not the problem, then I don't know why it's slowing down.
Reply
#8
I tried turning off Speedstep in the BIOS (underclocking) and it still didn't do the trick.
I've taken a look on the DELL forums but the only solution i found was to turn off speedstep, which i did.
Reply
#9
(01-20-2010, 02:09 AM)CrimsonMoonMist Wrote: I tried turning off Speedstep in the BIOS (underclocking) and it still didn't do the trick.
I've taken a look on the DELL forums but the only solution i found was to turn off speedstep, which i did.

It may not be an option. The last two laptops I've owned did it in hardware and couldn't be turned off, this may be the case with you.

Solution: only play PCSX2 when plugged in.
"This thread should be closed immediately, it causes parallel imagination and multiprocess hallucination" --ardhi
Reply
#10
Download and run CPU-Z while playing and check the CPU frequency.

Turn off C1E Enhanced Halt state if it's an option in the BIOS.
[Image: yunacopy.jpg]
Reply




Users browsing this thread: 1 Guest(s)