Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Slowdowns in a lot of games. looking for help
#1
My computer specs:
Windows 7 Home Premium 64-bit
3GB DDR3 RAM
HIS IceQ Radeon HD 5670 1GB GDDR5
Intel Pentium Dual Core E5800@ 3.20GHz
(more info on CPU http://www.cpubenchmark.net/cpu.php?cpu=...40+3.20GHz )
320GB 7200RPM Hard Drive

Hi I'm having trouble with slowdowns in games like kingdom hearts 2 and the bouncer. Kingdom hearts 2 stays at 60fps most of the time but there a lot of times it drops to 45 during battles sometimes. Im using pcsx2 0.9.8 4600 and messed with the graphic settings for example - trying native resolution, tried all six presets on the gs settings with no luck. If anyone knows how I can fix these problems it would be greatly appreciated. Thanks.
Reply

Sponsored links

#2
While on native resolution, what do the EE% and the GS% say at the top of the emulation window when you get slowdowns?

By the way, using presets in the GS tab changes nothing at all in that section.
Want to contribute? Don't know how? Check out the PCSX2 Wiki page!



Keep safe with MyWOT.

I have everything...
Reply
#3
(08-18-2011, 03:53 AM)majid25 Wrote: ... Im using pcsx2 0.9.8 4600 and messed with the graphic settings for example - trying native resolution, tried all six presets on the gs settings with no luck. If anyone knows how I can fix these problems it would be greatly appreciated. Thanks.

Wait-- You mean the "Preset" options found at the bottom of Emulation Settings? Changing it when under any tab there (including "GS" tab) will be applying changes throughout the Emulation Settings, including "Speedhacks".

... or something actually in the GS plugin settings...? Because increasing the resolution too much beyond "Native" will definitely become excessive for your GPU.
Reply
#4
Rezard - In the CoreGS settings i mean, on the bottom where you can set presets (safe, safer, agressive etc.) you have 6 options. I tried each one of those and made adjustments myself but still getting those slowdowns. What is weird though, on native and 3x native there is no difference at all, slowdowns happen at the same parts where it happens. But most of the time its at 60fps no problem. Just mostly on those boss fights and certain areas that screw me over.

MyDreamName -(This is using "Balanced" setting in Emulation/CoreGS settings: So basically speedhacks are enabled, EE Cycerlate is at "2" , VU Cycle Staealing is at "0", and Enable "INTC Spin Detection", "Wait Loop Detection", and mU Flag Hack" are checked) Alright so when the game is running normally no problems, the EE: stays around 70%, lowest it goes is like 57% and highest is 80% and the GS: stays around 30%. (Im playing right now and giving you information btw) - so currently the EE: is at 40% and GS is at 25%. Still running normally at 60fps, they seem to be never consistent. JUST got the slowdown, EE: went to 98% , GS: 35-45%.

I provided as much information as possible and hope I didnt drive you crazy with all this. I want to know what the problem is and why it does this. I believe specs are powerful enough to be running this thing. Thank You.
Reply
#5
If EE is not at 100% then you're being bottlenecked by the GPU.
Reply
#6
^
Code:
on native and 3x native there is no difference at all
I wouldn't be soo sure to say it's GPU looking at the aboveTongue

I guess reaching 100% EE can be hard on dual core CPU's as 100% means max it could get in perfect conditions, other programs runned in background can take off those 2% through. If EE boosts from 60-80% to 98% while having slowdown that's potentially cpu limiting the speed here.

As GS thread seems still fairly low even during those slowdowns, maybe using SVN version with MTVU speedhack could help a bit. Or using SuperVU as long as it's compatible it can give a few fps.
Reply
#7
^ Trust me, it's the GPU. I have a similar problem with Dirge of Cerberus. Small difference in FPS between native res and 3x but EE almost never reaches 100% because the GPU is holding back the CPU.

Run GPU-Z while playing in native res and I guarantee you will see 100% GPU load.
Reply
#8
So the graphic card is not strong enough? I just got this thing like 2 weeks ago and It runs all the latest games. Thing is, before this graphic card i used to use integrated Intel graphics that my comp came with. I used to get 60fps but the lowest It would go down would be 40 fps. I'm pretty sure It should be the CPU, because the graphic card had no effect on it then It's clearly not the gpu. If I have to get like a core i3,5,7 or any of those things I give up on ps2 emulation lol.
Reply
#9
(08-19-2011, 11:03 PM)synce Wrote: ^ Trust me, it's the GPU. I have a similar problem with Dirge of Cerberus. Small difference in FPS between native res and 3x but EE almost never reaches 100% because the GPU is holding back the CPU.

Run GPU-Z while playing in native res and I guarantee you will see 100% GPU load.

i did what you said and tried GPU-Z, on kingdom hearts I had 25-30% gpu load, and on The Bouncer it reached 90%. So what does that mean?
Reply




Users browsing this thread: 1 Guest(s)