Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Slowness is SoC with a fast PC.
#1
My specs are:

Intel Core i7-3630QM CPU @ 2.40GHz - 3.40GHz with Turbo Boost
ATI 7970M 2GB GDDR5

Which are supposedly more than enough to play most games at least with native speed. I've tried changing settings in the graphics plugin, but I can't tell any difference, even between min settings and 4x native resolution rendering with 8x MSAA etc. I'm playing SoC and I get 25-60fps depending on how much stuff is there to render. Changing display resolution also yields no effect.

The title bar of the emulator says the GS usage is in the 25-55, depending on the settings I put, but the EE usage is in the 95-100%. I don't know if I'm interpreting it correctly, but I think this means the slowness is caused by the CPU? Which is strange, because it's a Gen 3.5 Core-i7 (the very latest). If this isn't enough then nothing short of a cluster could get playable speeds. It's obvious then, that there is some problem, though I am at a loss as to what to do. If anybody could lend me a hand, that'd be great.

PS: Task manager shows 30-40% of CPU usage during emulation (CPU has 4 physical cores, 8 logical) vs 0-2% idle.

PPS: Windows benchmarks give 7.6 to the CPU and 7.1 to the GPU (that's quite high).
Reply

Sponsored links

#2
After setting VU cycle stealing and EE cycle speedup as per the wiki page on SoC I've gotten a substantial increase in, but I still have slowness up to 40fps. How come? The wiki page was tested with a Pentium Dual-Core E5400...
Reply
#3
You got warned twice and didnt listen. 3 strikes, youre out
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#4
I am reopening this thread as the user has now proved that he has the original disc via PM to me, but originally downloaded the game not realising he could have ripped his own disc.

This thread can continue.

Can you post pictures of your speedhacks tab and your GSDX settings?

also make sure your performance plan is set to "High performance" on your laptop.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#5
Yes, like you suggested, the CPU was being throttled. Fiddling with the settings and downloading the latest turboboost firmware did the trick. I now have constant 60fps. Thanks for the help and sorry again for the trouble.
Reply




Users browsing this thread: 1 Guest(s)