Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
So many issues to play a damn Game. (Shadow of the Colossus)
#1
Alright guys,

I don't even know where to begin.

My parents bought a PS3, without me being there. They got the PS3 Slim which they very much like. Now I haven't owned a PS2 or PS3 in a very long time. So I'm all excited and VERY MUCH want to show my girlfriend Shadow of the Colossus. She had only played it once before and well...

Okay, enough of that. I tried it on the PS3, and only to find out that PS3 slim nerfed being able to play PS2 backward compatible games. Sad

I was very disappointed, so I thought I would try a last resort. I downloaded a PS2 Emulator for my PC. ONLY to find out that I ALSO need to have a PS2 Bios from the internet. I did some checking around, and you guys obviously do not support that sort of thing. But now... is there a way I can use something from my PS3?

I've been having other issues as well... I ripped the ISO from my Shadow of the Colossus DVD and basically all works. After I configure everything, set my buttons and controls I try to go execute everything. Then I get two error messages about Memory Cards. *shrugs* I just want to be able to play the game, I don't care about saving right about now.

So basically, when I set everything... nothing saves. Not even my screen resolution, or button configurations. What can I do to fix all of that, so that it saves correctly?

Shadow of the Colossus is probably the only game I am ever going to play from this, and maybe Kingdom Hearts. I own these titles, and a PS3... that won't even play them. So I don't see what the problem is using my PC as the alternative.

If someone can help out, this would be greatly appreciated.

Thanks.
Reply

Sponsored links

#2
For your configuration saving you need to run PCSX2 as administrator (right click), and I'm sorry but as you said you do need a PS2 were to rip your BIOS to use the emulator legally, nothing you can do with a PS3.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#3
(10-04-2009, 06:11 AM)Shadow Lady Wrote: For your configuration saving you need to run PCSX2 as administrator (right click), and I'm sorry but as you said you do need a PS2 were to rip your BIOS to use the emulator legally, nothing you can do with a PS3.

Basically when I rightclick, the only option I have is "Open."
Reply
#4
Uhm then try moving the PCSX2 folder to your Documents folder.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#5
The title of this thread should be 'so many damn complaints to play a damn game' because it reeks of impatience and non-resourcefulness.

Anyway, are you running Vista? If so, there should be a 'Run as administrator' setting as Shadow Lady said. If you don't see it,
a) right click on the PCSX2 shortcut (in desktop or menu).
b) click on open file location button in the 'Shortcut' tab, the PCSX2 folder will open
c) find the pcsx2.exe file, right click on it
d) click the 'Compatibility' tab, and on the 'Privilege level' area, check the box beside the 'Run program as administrator' text
e) click 'Ok'

Run the shortcut again to see if the memory card msg comes up again.

As for the BIOS, yup you're gonna need an actual PS2 (or other illicit methods which I will not write down and should not be followed). PS3 hasn't been backwards compatible in ages, if you hadn't had one before you shouldn't be surprised that it isn't BC. When I bought mine all I wanted to play was PS3 games anyway. You should do some research about it.
Reply
#6
(10-04-2009, 08:15 AM)kramsy Wrote: The title of this thread should be 'so many damn complaints to play a damn game' because it reeks of impatience and non-resourcefulness.

Anyway, are you running Vista? If so, there should be a 'Run as administrator' setting as Shadow Lady said. If you don't see it,
a) right click on the PCSX2 shortcut (in desktop or menu).
b) click on open file location button in the 'Shortcut' tab, the PCSX2 folder will open
c) find the pcsx2.exe file, right click on it
d) click the 'Compatibility' tab, and on the 'Privilege level' area, check the box beside the 'Run program as administrator' text
e) click 'Ok'

Run the shortcut again to see if the memory card msg comes up again.

As for the BIOS, yup you're gonna need an actual PS2 (or other illicit methods which I will not write down and should not be followed). PS3 hasn't been backwards compatible in ages, if you hadn't had one before you shouldn't be surprised that it isn't BC. When I bought mine all I wanted to play was PS3 games anyway. You should do some research about it.

Thank you very much man, this is much more awesome.

The problem was, I right clicked the shortcut on my desktop, and for some reason it led me to this random folder with another shortcut in there. So basically I just went into the folder for PCSX2 and found what I needed there. You solved everything just by me doing that, thanks man. lol

Also, why do you need to be so irritable when someone asks for help? This vista has terrible issues for me, I'm not used to it. I've even started having trouble with my new mouse recognizing properly, it is quite annoying. There are so many problems I've had with Vista so far. So don't get me started. Wink
Reply
#7
95% of people's "problems" with Vista are operator error.
http://www.twitch.tv/krazytrumpeter05
Want to stream your games? Let me know and I can help you get set up with Open Broadcaster Software.
Reply




Users browsing this thread: 1 Guest(s)