Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
SoTC good FPS, but laggy still?
#1
Ok I have a strange problem.

First of all let me start with all the info

system -

- i7 930 - 2.8ghz
- XFX HD5970 2gb
- 6gb RAM DDR3

PCSX2 version -

- 0.9.7 also have 0.9.7 r3113
- US ISO of SoTC (ripped it with ISO maker)

Now my issue...

I am able to play the game at a constant 60fps, it never dipps. When I disable frame limiter it even goes over 200fps at times which is WAY too fast, and looks strange, everything is like in fast forward.

When I enable frame limiter to 60fps it says it's playing at 60fps, but it looks REALLY laggy, like it's at 20 or something, fraps even confirms it's at a constant 60fps. I even tried putting the NTSC framerate to like 100, and it still looks very laggy, but says 100.

What can I do to make the gameplay look smooth? I really dont like playing with the frame limiter off.

Thanks for the help, and I can post any pics or info if you need it.

EDIT:

[Image: aasoz.jpg]
Reply

Sponsored links

#2
I think it's the way the game itself is designed. It reminds me of old N64 days, where games like Turok 2 felt really slow, but it was intended.
Intel i5 3450
AsRock B75-Pro3-M
Sapphire R9 290 Tri-X OC
8GB DDR3-1333 RAM
Sandisk Ultra Plus 256GB
Seagate 7200.14 1TB x2
Enermax Triathlor 450W PSU
Reply
#3
The EE cyclerate and VU cycle stealing speedhacks can produce that so try without them.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#4
Quote:I am able to play the game at a constant 60fps, it never dipps. When I disable frame limiter it even goes over 200fps at times which is WAY too fast, and looks strange, everything is like in fast forward.

Post your fps with no speedhacks on.
Reply
#5
Ok shadow lady ill try without those on, what is the BEST version of PCSX2 to date to use for this game? This game is all I really want to play on the emulator, because it looks so crappy on my PS2, lol.
Reply
#6
(06-29-2010, 07:12 AM)Ænigmatik Wrote:
Quote:I am able to play the game at a constant 60fps, it never dipps. When I disable frame limiter it even goes over 200fps at times which is WAY too fast, and looks strange, everything is like in fast forward.

Post your fps with no speedhacks on.
With speedhacks off it seems to hurt performance, this is with them on and frame limiter off.

[Image: pcsx2-r31132010-06-2822-14-39-78.jpg?t=1277788917]
[Image: pcsx2-r31132010-06-2822-14-57-37.jpg?t=1277788918]
[Image: pcsx2-r31132010-06-2822-15-25-96.jpg?t=1277788918]
[Image: pcsx2-r31132010-06-2822-15-57-21.jpg?t=1277788920]
[Image: pcsx2-r31132010-06-2822-16-05-05.jpg?t=1277788920]
[Image: pcsx2-r31132010-06-2822-16-20-36.jpg?t=1277788923]
Reply
#7
How bout upping the FPS limit a bit me this game play's well on 65fps for me
My New PC
[Image: 1714419.png]
[Image: stargate_sg_1_stamp_by_OmegaDreamSeeker11.jpg]
Reply
#8
Hey shadow lady, it worked! The game feels normal now, BUT now it plays at only 40fps =(

EDIT: Ok got it working 60fps constant.

Turned EE all the way up and VU all the way down. =P

[Image: pcsx2-r31132010-06-2822-36-41-64.jpg?t=1277789940]
[Image: pcsx2-r31132010-06-2822-36-34-90.jpg?t=1277789941]
[Image: pcsx2-r31132010-06-2822-36-11-05.jpg?t=1277789942]
[Image: pcsx2-r31132010-06-2822-40-35-77.jpg?t=1277790129]
Reply
#9
Increases in fps from speedhacks can be misleading.
Reply
#10
With x3 scailing, makes it look much better.

[Image: pcsx2-r31132010-06-2822-43-18-80.jpg?t=1277790297]
Reply




Users browsing this thread: 1 Guest(s)