Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Software OK, Hardware not working!
#1
Sad 
Hi to all and Merry Christmas!

I just installed PCSX2, since my PS2 died on me Sad

I am trying to play my Gran Turismo 4, but I have a problem with the video driver ( GSdx 4600 – MSVC 15.00):

I started with SSE41 and hardware acceleration, and it ‘s all good, booting, main menu, select car (when car is shown the FPS drops from 60 to about 40 but I do not think this is important), select stage, everything up to the race itself.
The second the race loads, the screen is filled with artifacts (?) but I can still see the speed/revs dials and stuff. The game still runs, but I just see some weird colors and nothing more. When I press “start” the menu box is seen just fine, I can exit the race and all.

When I switch to software acceleration ( GSdx set at “Direct3D9(Software)” ) the game works fine (and in race) but is unplayable because of the ridiculous frame rate, it is like I am in bullet-time (slow motion).

I tried to use SSE2 and tried all the other settings on the tab (like “Alpha correction” “Resolution” etc) , but it is exactly the same thing, hardware does not work.

I have lots of PC games and I never had a problem, everything works fine.

Any ideas guys?

PC:
Intel Core2Duo E8500
4GB RAM
Asus GTX275
Windows XP SP3

Thanks in advance,
John


Attached Files Thumbnail(s)
   
Reply

Sponsored links

#2
1 - comparing native PC games to emulation is a complete nonsense.
2 - go to the ingame settings and set brightness to 0.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
(12-25-2011, 08:59 PM)jesalvein Wrote: 1 - comparing native PC games to emulation is a complete nonsense.
2 - go to the ingame settings and set brightness to 0.

I tried that, it is on zero.I should have mentioned that, sorry.

I agree that an emulator is not perfect, but I think that I can run the game IF I can get it to work at hardware. I say that because when in hardware and while I cannot see anything, the game runs at full speed, engine revs like It should, frames at 59, just by the sound I can tell I am not in “slow motion” like on software.
I told that so that you know that I do not have any windows/nVidia driver issues in general.

Thanks for the answer though! Smile
Reply
#4
I see.
Tried latest SVN ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#5
Svn is the version, right?

I downloaded the PCSX2 tree days ago, it is V0.9.8 r4600

Also I do not use speedhacks (actually I tried but nothing improved). Also tried Normal and 480i modes, but nothing changed.
Reply
#6
(12-25-2011, 09:56 PM)Johnny Wrote: Svn is the version, right?

I downloaded the PCSX2 tree days ago, it is V0.9.8 r4600

Also I do not use speedhacks (actually I tried but nothing improved)

SVN revisions are small fixes that are released several times a day, with hundreds of these small fixes culminating into an official release at a later date.

For the most recent SVN Revisions, you can always check here:
http://pcsx2.net/svn.php

The newest revision is 5016 and yours is at 4600, a fairly significant difference! It wouldn't hurt trying a newer revision to see if your problem is fixed.
Reply
#7
(12-25-2011, 10:05 PM)FlotsamX Wrote: SVN revisions are usually small fixes that are released several times a day, with hundreds of these small fixes culminating into an official release at a later date.

For the most recent SVN Revisions, you can always check here:
http://pcsx2.net/svn.php

The newest revision is 5016 and yours is at 4600, a fairly significant difference! It wouldn't hurt trying a newer revision to see if your problem is fixed.
Thanks! I will try that right now.

Reply
#8
Success!!! Smile Smile Smile

The game now works in race too! Once I installed the new files, I just started the game and set-up the settings (including brightness to zero) the way I like them (music, miles etc), and game works fine.
I used again GSdx9 but the 5016 version, all default like before. I only changed the interlacing to “Blend tff” because the screen “jumped around” a bit, but game still works. I think the overall graphics are better now too, before I could not read the words that well.

Still the game does some drops in the framerate, like it did before in the showcase, but I can run a race now! I just gave it a go at a license or two, I will play around with the settings to see if I get it to run better.

Thank you all for your help,
and happy holidays to all!
Reply




Users browsing this thread: 1 Guest(s)