Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Solved] Buggy/Skipping Sound in all games--help!
#1
Hello PCSX2 forums!

I recently installed PCSX2 onto my windows machine (specs below), and everything is working great, except for the sound. I've tinkered with the sound plugin (using the default SPU2-X), but I can't seem to fix it through those settings. What's happening is that in the games I've tried (SMT: Nocturne, Fullmetal Alchemist and the Broken Angel, Digital Devil Saga, and Katamari Damacy) the sound skips horribly in all scenarios, from FMVs to gameplay to menus. I've tried switching sound sources from the GPU HDMI connector to the headphone port on the mobo, but that didn't solve the problem either.

If you have any suggestions on how to fix this issue or need more information, please let me know. I'm really at a loss and have no idea what else to try. Thanks in advanced!

Edit: realized my signature isn't working right. Here are the system specs I'm working with:

Intel Core i7-3770k
Gigabyte Sniper M.3 Z77 mobo
Gigabyte AMD 7950 3GB
8gb 1600mHz RAM
Asus Blu-Ray Drive
TP-Link Wifi Card
2tb HDD
120gb Corsair F120 SSD
OS: Windows 7 Professional 64-bit, Ubuntu 12.04 LTS 64-bit
PCSX2 ver., 1.0.0
Reply

Sponsored links

#2
Can you post your pcsx2 settings please.

Ensure you're running them with the fps limiter on, or you're not stuck in turbo mode etc, as that will naturally cause the sound to skip and stutter.

I need more info, regarding your current settings and what rev of pcsx2 you're using etc


#Edit: typo
Reply
#3
Okay, I'm using the default settings for most things with PCSX2 ver 1.0.0 r5350. Here's what I've changed:

Video Plugin: GSDX 5334 gsdx32 r5350
-Renderer: Direct 3D11 (Hardware)
-Interlacing: Weave bff (saw-tooth)
-Native PS2 Resolution
-Texture Filtering and Allow 8-Bit Textures enabled
-MSAA x16 enabled under 'configure'
-WildArmsOffset enabled under 'configure'
-Extra Rendering Threads 0
-Enabled Edge anti-aliasing (AA1)

Sound Plugin: SPU2-X r5324 rev 2.0.0 [spu2-x-r5350]
-Interpolation set to 3 - Hermite
-Module set to 2 -Direct Sound
-Synchronizing Mode set to TimeStretch
-Audio Expansion set to Stereo
-No other boxes checked within the plugin

I'm also using the BIOS version USA 2.20 (10/02/2006) and running the games from .iso files made with ImgBurn.

I do have the FPS limiter on. When I turn it off, my FPS jumps up to 300+ fps, so the games are unplayable otherwise (the sound is also buggy with framelimiting disabled). I am also not in turbo mode; the FPS stays around 59-60 at all times.
Reply
#4
-MSAA x16 enabled under 'configure'

Pretty much will kill every game you try to run. I know that videocard will munch for lunch any PC game you throw at it... but this is emulation, worse yet, MSAA is yet at experimental phase and is just a plus, it's not something the PS2 has to be emulated.

Better results will be achieved with greater internal resolution and possibly a more modest MSAA. Be aware that even then, certain games might not like any the two. Yes, is more game dependent than the emulator itself, till each "particularity" is chased down someday in the future.
Imagination is where we are truly real
Reply
#5
(12-04-2012, 08:43 PM)nosisab Ken Keleh Wrote: -MSAA x16 enabled under 'configure'

Pretty much will kill every game you try to run. I know that videocard will munch for lunch any PC game you throw at it... but this is emulation, worse yet, MSAA is yet in experimental stage and is just a plus, it's not something the PS2 have to be emulated.

Better results will be achieved with greater internal resolution and possibly a more modest MSAA. Be aware that even them, certain games might not like any the two. Yes, is more game dependent than the emulator itself, till each "particularity" is chased down someday in the future.

Okay, disabled the MSAA x16 and the sounds are still stuttering as they were before.

Edit: I'd easily contribute the problem to the game if it were just 1 title, but so far all of my .iso's (all of which I've been making from my personal PS2 collection) have the same issue, so it seems more likely to be something strange in the configs I'm not finding on my own.
Reply
#6
(12-04-2012, 08:53 PM)obsidian1200 Wrote: Okay, disabled the MSAA x16 and the sounds are still stuttering as they were before.

Edit: I'd easily contribute the problem to the game if it were just 1 title, but so far all of my .iso's (all of which I've been making from my personal PS2 collection) have the same issue, so it seems more likely to be something strange in the configs I'm not finding on my own.

Anyway, that msaa x16 would be problem and better keeping it at bay.

Verify the speedhacks, maybe you set some preset at the installation which enabled them.
Imagination is where we are truly real
Reply
#7
The Speedhacks were enabled. I disabled them and tried relaunching the .isos. Sound issues were still present and seemed to be more frequent than before.
Reply
#8
(12-04-2012, 09:06 PM)obsidian1200 Wrote: The Speedhacks were enabled. I disabled them and tried relaunching the .isos. Sound issues were still present and seemed to be more frequent than before.

then you removed the speedhacks and things got worse?

Well, at this point the sensible attempt is deleting the whole PCSX2 folder, reinstall it making sure it's not at C:\Program files (use the portable version).

If still having issues playing any emulated game with that machine... take it to an exorcist Smile

Edit: of course is not to delete the memcards and absolutely to not delete the ISOs and the BIOS..., but make sure all ini files are deleted so they can be reconstructed from the default.
Imagination is where we are truly real
Reply
#9
Alright, so doing a wipe and reinstall fixed most of my issues. The only game still giving me problems is Nocturne, but seeing as how that has no spoken dialogue, playing it on mute with the soundtrack playing in the background will do just fine. Thanks for the help guys, now time to tackle converting some of my PS2 savegames into the PCSX2 format!

Edit: okay, this is weird. I rebooted to do some work in Ubuntu earlier today and when I went back into W7 and booted up Nocturne, even that was working perfectly. I may need to call an exorcist after all haha!
Reply




Users browsing this thread: 1 Guest(s)