Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Solved] FF XII graphical glitch
#1
Hello. I've experienced a rather annoying graphical glitch in the first town of the game that causes some walls and buildings to dissapear. This happens when using hardware mode only, in software mode it works fine. here are a couple of pictures that show the issue:

Hardware mode DX11 and 9 (occurs in both):
[Image: 8287005ffx12_glitch.jpg]

Software mode, works fine:
[Image: 7431113ffx12_noglitch.jpg]

Settings are all set to default, and I use the AVX version of GSdx (I tried the other ones too, SSE4, etc, same thing happens).

Does anyone know what could be wrong here?

My comp specs are:
-CPU: i5 3570k
-GPU: Intel HD 4000 (the one that comes with the cpu, latest drivers, no laptop)
-RAM: DDR3 1800 8 Gb Dual
-Motherboard: Intel Z77 Extreme 4

[Image: 6148062specs.png]

If you need more info tell me and I'll post it. Thank you very much for your help.
Reply

Sponsored links

#2
Have you tried turning off speed hacks, and re-test? you can do this quickly, by opening up the emulation settings, and ticking the preset checkbox (bottom left of the dialog) and selecting 'safest'

If you can maintain full speed without hacks (other than maybe the MTVU hack for quad+ cores) then you shouldn't use them, unless you need them. You can adjust the preset as needed, if you need more speed. Edit: typo

If you cba using a preset,
If it is hacks causing the issue, turn each of them on, one by one, and find out which is causing it, then leave that disabled.
Reply
#3
(04-02-2013, 04:42 PM)Asmodean Wrote: Have you tried turning off speed hacks, and re-test? you can do this quickly, by opening up the emulation settings, and ticking the preset checkbox (bottom left of the dialog) and selecting 'safest'

If you can maintain full speed without hacks (other than maybe the MTVU hack for quad+ cores) then you shouldn't use them, unless you need them. You can adjust the preset as needed, if you need more speed. Edit: typo

If you cba using a preset,
If it is hacks causing the issue, turn each of them on, one by one, and find out which is causing it, then leave that disabled.

I just tried with all hacks off setting safest tick on but no luck. Then I'm not sure what 'cba' means?
Reply
#4
Hmm, What version of PCSX2 do you have? I haven't gotten around to playing FFXII on PCSX2 yet, but I don't see anything regarding this on the Wiki. If it was a common glitch, It should be there, I'd imagine.

I'd say its only for that area, if I'd to guess, else we'd have people raving like lunatics about this, well by now lol, Continue on, for the time being, if you can't find a resolution right now. It's probably fine past that area.

cba, only means - can't be arsed, by the way.
Reply
#5
(04-02-2013, 04:57 PM)Asmodean Wrote: Hmm, What version of PCSX2 do you have? I haven't gotten around to playing FFXII on PCSX2 yet, but I don't see anything regarding this on the Wiki. If it was a common glitch, It should be there, I'd imagine.

I'd say its only for that area, if I'd to guess, else we'd have people raving like lunatics about this, well by now lol, Continue on, for the time being, if you can't find a resolution right now. It's probably fine past that area.

cba, only means - can't be arsed, by the way.

It's the 1.0.0 apparently. I'll just drop this screen here so you see for yourself. Smile

[Image: 6148062specs.png]

Edit: It might actually be a problem related to Intel drivers, because nVidia cards do not seem to have this problem. Well, I seem to get full fps speed using software mode, so I guess I'll play that way. Unless a fellow finds a solutions to this, of course. Laugh Thanks for the help, I really apreciate it.
Reply
#6
been playing it for a while, 2nd run, 0 disappearing walls xDD

Maybe it's something with the intel card, no idea, tested it on both amd and nvidia and game works fine, try svn version with latest gsdx plugin, maybe it fixes some stuff Smile

That gsdx should be SSE4, not avx, change it on plugin selector (nvm I think I'm wrong on this, but try it anyways xD)
Reply
#7
Now that I think about it, It could possibly be an issue with the Intel integrated gpu, with that game on the emulator. I'm only taking a guess, from the look of the screen shots. You'll have to wait for somebody else who has encountered this problem before with this game, I'm afraid. GL.

Edit: Above poster got there before me Tongue

Also, the CPU instruction set used would have no implications to this, whatsoever. AVX is fine.
Reply
#8
Oh wow, actually using the lastest GSdx SVN build (r5604 I just downloaded it) solves the issue. Very nice indeed. Now I'm very curious to know which was the commit that actually fixed this bug. Laugh

Anyways, I hope this can help someone else with the same problem.
Reply
#9
also make sure Zhek, that you DON'T install PCSX2 into Program Files, Windows 7 still has a permission bug, which they just refuse to fix, which can make it a bit harder for PCSX2, with some games Smile C:\PCSX2 for example will work just fine Smile
Reply
#10
Wow a 3570K system without a dedicated GPU that is just sad to be honest. Mine is paired up with a NVIDIA GTX 660 TI since my monitor is only 1680x1050.
Reply




Users browsing this thread: 1 Guest(s)