Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Solved] Weird lag in Midnight Club 3 DUB Edition Remix
#1
Star 
Heyo forums Smile

So, since I got my new GTX980ti, I thought it would be a good idea to try PS2 emulation again. Much to my disappointment, I did not get Midnight Club running smoothly at all. It actually runs quite horribly on Hardware mode, and has ocassional slowdowns in Software mode.

In hardware-mode, the system does not seem to be bottlenecking at all. The GS is running close to 100% all the time (which does not seem to be a GPU-Bottleneck tho [the GPU pretty much hovers around 15-20% Usage], raising the EE-Clock didn't help much either.) my FPS is 60 when standing still, ~55 while driving, sometimes dips into the 40s. Also there are some graphical issues, but I read that this is normal for hardware-mode. I also tried several SkipDraw settings (1-10), none of which helped.

In software-mode, things look much better. The FPS are not as bad most times, but they do dip to ~45FPS (especially in races). The reason for that is a CPU-Bottleneck tho (CPU-Usage ramping up to 100%).

The thing that is baffeling to me is that someone with a 1st-Gen Intel i5 was able to play this game smoothly on youtube. What is wrong?

Emulation Info:
PCSX Version: PCSX 1.4.0
Game: Midnight Club 3 - DUB Edition Remix (NTSC-U) [SLUS-21355]
Settings: Here.

Rig:
CPU: Intel i5-3450 (3.10GHz Quadcore)
GPU: Nvidia Geforce GTX980Ti (Gigabyte Xtreme Gaming-Edition)
RAM: 16GB (4x4GB, DDR3)


Edit - The problem has been resolved by using this method:
(04-29-2016, 02:11 PM)refraction Wrote: Tick "Allow 8bit Textures"
Tick "Enable HW Hacks"

OK it and close PCSX2, then in the "ini" folder edit the gsdx.ini and put this line at the bottom

UserHacks_DisablePartialInvalidation = 1

Many thanks to refraction! Smile
Reply

Sponsored links

#2
Try the latest development build from here with GSDX set to OpenGL, we have made some optimisations to the GS since 1.4.0 Smile http://buildbot.orphis.net/pcsx2/
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#3
Alright, thanks for the suggestion Smile

I tried the newest available version (v1.5.0-dev-675-g35e1712) with OpenGL Hardware-Mode and Software-Mode. I reproduced my old settings as close as possible. The OpenGL Hardware-Mode seems to be a bit glitchier than the Dx11-Varient I used in 1.4.0 (Extreme bloom at some spots, glitchy HUD and textures, etc.), and I had the exact same slowdowns. The Software-Mode seems to have been slower than before (?), atleast for me.

Again, on Hardware-Mode, the GS jumped up to 100%, although my GPU didn't break a sweat (~27% usage). It's just really strange.
Reply
#4
Can you show us your GSDX settings please?
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#5
Alright, no problem Smile -- Here ya go!
Reply
#6
Thanks!

Ok some things to try.

Tick "Allow 8bit Textures"
Tick "Enable HW Hacks"

OK it and close PCSX2, then in the "ini" folder edit the gsdx.ini and put this line at the bottom

UserHacks_DisablePartialInvalidation = 1

See if that makes any difference Smile
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#7
That does make a HUGE difference! The game runs much smoother with that setting, I get good FPS even at 4K. Thank you very much Smile

Another question, is there a way to get rid of the big glitching texture in the lower left? It's pretty distracting Sad
Reply
#8
Possibly not, that looks like a similar effect to destroy all humans which isn't fixed either. you could try messing with the skipdraw setting under the hw hacks section of GSDX and hope for the best.

I doubt it would help but first you could try the hardware depth + accurate date options, you might need to put the CRC level down to Minimum (OpenGL Recommended). But if you aren't using OpenGL none of those options will help/work Smile
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#9
None of those helped unfortunately. But thanks anyways, appreciate it Blush
Reply
#10
I think skipdraw 6 is what helps destroy all humans, it's usually a good idea to try 1 through 10, if that doesn't work, you're generally screwed Tongue
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply




Users browsing this thread: 1 Guest(s)