Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Some kinda texture bug? (Ar Tonelico 2/Mana Khemia 2)
#1
Hello,

I've played around with all the settings in hopes of gettin those pesky lines out with little result,

       

Those screenshots were both taken on betar1736 and gsdx1736 using hardware directx10 on native resolution. Using a custom d3d internal res will only add the usual black lines, texture filtering doesn't solve it either, turning off speedhacks, interlacing, etc has no effect either.
Running in software mode does get rid of them, but for reasons I also can't understand, it eventually breaks the game, not to mention the lower speed compared to the hardware mode. I did search through the forums, if I missed the thread with a solution, do tell me please.

Maybe relevant information:
Core2Quad Q9300 @2.50GHz
4,00GBRam
Windows Vista Ultimate 64bit
NVIDIA GeForce 8800 GTX, Driver Version: 190.38
Reply

Sponsored links

#2
These errors are odd indeed. Have you msaa turned on by chance?
You could try a few older versions of GSdx, see if any of them fixes it.
Reply
#3
(09-23-2009, 10:13 PM)rama Wrote: These errors are odd indeed. Have you msaa turned on by chance?
You could try a few older versions of GSdx, see if any of them fixes it.

This comes from the texture filtering.When you use custom resolution and disable the texture filtering(I can't disable it in native mode)this problem will disappear but the graphic will look little bad because of the disabled texture filtering but you can use some of the blend interlacing modes to reduce this effect of the disabled texture filtering.
Reply
#4
Have you tryed dx9 there were some games that i have that had lines on dx10 but not on dx9 ( if i am not mistaken).
C2D E6550 @ 2333 Mhz oc 3010 Mhz vcore 1.2750v | HD2600XT | P5KC | 1 + 1 GB G.Skill 6400HK 860 4.4.3.5
Reply
#5
(09-23-2009, 10:24 PM)seinfeldx Wrote: Have you tryed dx9 there were some games that i have that had lines on dx10 but not on dx9 ( if i am not mistaken).

I use DX9 and those lines are there.They are removed ones I disable the texture filtering
Reply
#6
(09-23-2009, 10:13 PM)rama Wrote: These errors are odd indeed. Have you msaa turned on by chance?
You could try a few older versions of GSdx, see if any of them fixes it.
A older version did solve it, but it seems vsub was right tho.

(09-23-2009, 10:21 PM)vsub Wrote: This comes from the texture filtering.When you use custom resolution and disable the texture filtering(I can't disable it in native mode)this problem will disappear but the graphic will look little bad because of the disabled texture filtering but you can use some of the blend interlacing modes to reduce this effect of the disabled texture filtering.
You were right, never had thought of that since I always played in native, the black lines bother me >.>

(09-23-2009, 10:24 PM)seinfeldx Wrote: Have you tryed dx9 there were some games that i have that had lines on dx10 but not on dx9 ( if i am not mistaken).

I had tried both, vsub's reply is right tho, and I guess theres not much to do about it but hope for a fix in the next version. *shrugs*
Reply
#7
It's kinda ok with the newest official GSdx(not beta)
Reply
#8
Well, GSdx's built in texture filtering (the half ticked option) should not cause these lines.
Must be a precision problem then yet again. Good to know another test game for this though Tongue2
Reply
#9
Right after vsub specified what the problem was I tried the half ticked one, no luck.
Reply
#10
Ok I found where this problem started,it's on GSdx-r1375.
On GSdx-r1372 is ok but the characters have black borders around them.
Reply




Users browsing this thread: 1 Guest(s)