Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Soul Calibur II - very blurry
#1
Hello all,

I'm trying to get Soul Calibur II to work. I have PCSX2 1.2.1. The game is extremely blurry. I searched around for a solution and messed around with settings for about half an hour, but no luck. Sad

Here is a screenshot:
http://imgur.com/oQt9JYN

This is with the final settings after messing with them for a while. But it looked pretty much the same with the default untouched settings as well.


If you need additional info in order to be able to help, please let me know what else you'd like to know.

My PC specs (if relevant) are GTX970, i7-4790K, 16GB RAM, Win7 64x.

Thanks in advance!
Reply

Sponsored links

#2
try the latest development builds from here and provide the status of the issue.

by the way, does software renderer help to fix the problem ?
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#3
Try pressing F6 a few times, the game has heavy interlacing.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#4
Maybe increasing internal resolution?
Reply
#5
(06-08-2015, 03:25 PM)ssakash Wrote: try the latest development builds from here and provide the status of the issue.

I uninstalled the previous version, wiped my settings, and installed the latest dev build (v1.3.1-492-gce5ccf8). Sadly, the blurriness is still there. Sad

Here is how it looks with default settings on the latest dev build:
http://imgur.com/vFJtzjg,NkoyLHe#0
http://imgur.com/vFJtzjg,NkoyLHe#1

(06-08-2015, 03:25 PM)ssakash Wrote: by the way, does software renderer help to fix the problem ?

Sadly, no. It doesn't seem to help. Here's how it looks with the renderer set to "Direct3D9 (Software)":
http://imgur.com/B7QzJDL

(06-08-2015, 03:27 PM)refraction Wrote: Try pressing F6 a few times, the game has heavy interlacing.

Tried that. Unfortunately that didn't help either. Sad

(06-08-2015, 05:45 PM)willkuer Wrote: Maybe increasing internal resolution?

I think it did seem to get slightly better with a higher internal resolution, but the blurriness was still there.


Any chance someone has a working setting configuration they can share for the game? Do the default settings for the game normally work perfectly fine, and it's just some kind of compatibility problem with my hardware? I can try it with another machine or two if you think that would help.
Reply
#6
Oh wait, I think I made some progress! I switched through the deinterlace modes with F5, and "Weave tff" seems to make things much sharper.

http://imgur.com/pYcjyTy


Now I just need to figure out how I can best stretch the game to fit a 1920x1080 screen. :-)
Reply
#7
config>emulation settings>gs window

change aspect ration from 4:3 to 16:9

Then go to system> enable widescreen patches
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply
#8
(06-08-2015, 07:06 PM)Nobbs66 Wrote: config>emulation settings>gs window

change aspect ration from 4:3 to 16:9

Then go to system> enable widescreen patches

Hmm, didn't seem to do anything.

Also, increasing the internal resolution actually seemed to make things more blurry. (I tried 1260x709 and 1248x702. On anything above 1260-wide the infamous vertical lines begin to show up all over the place.)

Here's the best I could get:
http://imgur.com/jIpmbjA
I guess this is as good as it gets? There aren't any postprocessing filters I can apply to it to make it sharper, are there?

Thanks for all the help. :-)
Reply
#9
Whats wrong with that? That's pretty good for PS2 Tongue

You could turn texture filtering off, but that will make some stuff look crap, but it'll be clearer
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#10
(06-08-2015, 07:23 PM)Obuw Wrote: Hmm, didn't seem to do anything.

Also, increasing the internal resolution actually seemed to make things more blurry. (I tried 1260x709 and 1248x702. On anything above 1260-wide the infamous vertical lines begin to show up all over the place.)

Here's the best I could get:
http://imgur.com/jIpmbjA
I guess this is as good as it gets? There aren't any postprocessing filters I can apply to it to make it sharper, are there?

Thanks for all the help. :-)

That looks great really Tongue
[Image: newsig.jpg]
Reply




Users browsing this thread: 1 Guest(s)