Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Sound beeps in FFXII
#1
Hi! ^^.

I've been experiencing some weird "beep" sounds ingame. The one which annoys me mostly is FFXII because it's very uncommon, I'm wondering if a savegame can help in the issue, because the sound problems seem to appear everytime I load the specific savegame Sad.

It seems to be related to footstep sounds and squaresoft games though. I've never had it happen on DMC1/2 or GoW. The problem is even more noticeable with the "The Bouncer" game (from square, too), where almost every sound comes out as an annoying beep :/.

I'm using the latest public beta and plugins (gsdx 1873 w/DX10 & 1280x1024 res, SPU2-X default settings, lilypad and no speedhacks or microVU). I once solved it because somehow I had changed the interpolation to zero (no interpolation) and then when I started to get the beeps I changed it to Linear and it stopped bleeping. Well, until tonight when I started the game with the latest savegame and it started bleeping again :/.

Is there anyobody else with the same problem, or with ideas on what to try? would it help to post the mcd, or save state?

Thanks in advance! Smile
..:: Core2Duo E7500 OC @ 3.23 Ghz | 9800GTX+ 512Mb GDDR2 | 2GB DDR2 800 | Win7 x64 ::..
Reply

Sponsored links

#2
By savegame do you mean save state? If you have a bug in emulation, savestates will restore the bug each time you load it. Best bet as a temporary solution is to make a normal save game (to virtual memory card) restart the emu, then load that memory card.

Which version of SPU2x, as there have been a few versions released lately, and one of them had some bugs with the PS2 reverb.
[Image: 2748844.png]
Reply
#3
Could try just using ZeroSPU2 instead too (without save states).
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#4
(12-07-2009, 08:38 AM)Koji Wrote: By savegame do you mean save state? If you have a bug in emulation, savestates will restore the bug each time you load it. Best bet as a temporary solution is to make a normal save game (to virtual memory card) restart the emu, then load that memory card.

Which version of SPU2x, as there have been a few versions released lately, and one of them had some bugs with the PS2 reverb.

I've tried both actually, savegame and savestate, and they both cause the same problem.

SPU2x is "spu2-x-r1857.dll", the one which came with the September 2009 plugins pack.

(12-07-2009, 09:16 AM)Shadow Lady Wrote: Could try just using ZeroSPU2 instead too (without save states).
Hm, I didn't try ZeroSPU2 since it sounded really crappy and weird in the BIOS and I didn't want to listen to the game like that from now on Sad XD but I guess I could try...

On another note though! I just tried PCSX2 from yesterday's SVN and the problem does seems to be fixed Laugh.

If I use SPU2x 1.2.0 or r2217 1.3.0 (newest) with the official beta, it has beep errors. However, if I use SPU2x 1.2.0 with SVN, it has beep errors!. The problem seems to go away when I use SPU2x r2217 1.3.0 and SVN, else it starts to beep again Sad

Oh well, guess I'll have to play with SVN for the time being x)
..:: Core2Duo E7500 OC @ 3.23 Ghz | 9800GTX+ 512Mb GDDR2 | 2GB DDR2 800 | Win7 x64 ::..
Reply




Users browsing this thread: 1 Guest(s)