Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Sound issue!
#1
Well, sorry in advance if I've missed a similar thread - but i don't want to scroll/browse through 10+ pages and the search function didn't show me what I'm after.

Anyway, the games Devil May Cry 1 and 2 works just fine in-game, graphics and sound works well - except for one thing: All the included sound plugins except one gives of one problem after another, one works well with two while the second game only works with the third. In which case the sound plugin "ZeroSPU2" works best with both games, except for the cracking sound. Even if the two first functions within this plugin are enabled I still receive cracking when "loud" sounds like shooting/spamming the pistols or when big doors shuts/opens. I can survive for the "cracking" door sound but not for the pistols - it completely destroys the gameplay. One other plugin works well for DMC1 but kills the background sounds in DMC2 so i prefer to use Zero's plugin since it works for both, I'm just got damn annoyed wit the cracking.

The sound timing is fine and plays all the sound(s) excellent, smooth gameplay overall - but like I said about the cracking sound, it's REALLY hard to concentrate on the game. I've tested/tried the others but i wasn't satisfied with the results - the SPU2 keep stutter the sound.

PCSX2 0.9.6
Windows 7 64-bit
Reply

Sponsored links

#2
It's a known issue and a hard one to fix. SPU2-X has nasty buffer overflows when shooting (especially in devil trigger mode) for which there is no solution yet.
[Image: newsig.jpg]
Reply
#3
(02-06-2010, 12:34 PM)Bositman Wrote: It's a known issue and a hard one to fix. SPU2-X has nasty buffer overflows when shooting (especially in devil trigger mode) for which there is no solution yet.

Well by disabling Time streching, audio expansion and effects processing the plugin SPU2-X sounds pretty good - except for the background noise. ZeroSPU2's plugin is so far better in sound but cracks when loud sounds from the guns and other high-peaked sounds plays.
Reply
#4
Well i don't know if i really managed to solve this sound issue, but i replaced the SPU2-X plugin with the latest beta and now both games sounds good. So, problem solved i guess.

Edit:

Alrought the sound tends to stutter when "alot" is happening in fullscreen and some in high-res Windowed - any thoughts about this?

I'm at the moment at this boss where the sound is the main issue - even if the beta plugin already helps alot it still seems either the plugin or the CPU can't handle it.

[Image: dmc1c.th.jpg]

Edit 2:

Maybe i should post about my PC and the current settings:

Core 2 Duo P8600 2.4Ghz @ 2.7Ghz
4GB DDR2 800Mhz
5400RPM HDD
Geforce GTX 260M @ 550/950/1375
Windows 7 64-bit Home Premium

PCSX2 0.9.6
GSDX 890
D3D 10 Hardware, Bob tff, 4:3, Texture filtering, Vsync, Windowed (otherwise i use 144x900 fullscreen)

No speedhacks than the defaults, although I've tried some but didn't experience any improvements.
Reply




Users browsing this thread: 1 Guest(s)