Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Specs for Ratchet & Clank at 4K 60FPS?
#1
Hello! I was running R&C on my PC and noticed dips in the FPS, at times going into the 40's. What kind of specs should I be looking for if I want to run this game at 4K 60FPS with no slowdowns? Here are my specs:

CPU: Intel Core i7 6800K 3.4 GHz (4.2 GHz OC, Six Cores)
GPU: EVGA FTW3 GeForce GTX 1080 Ti
RAM: Kingston HyperX 24GB (3x8GB) DDR4 2133MHz
MOBO: ASUS X99-A II
HDD: WD Blue 1TB 7200RPM

I am running PCSX2 v1.5 in DX11 Hardware Mode with 5x native resolution and no speed hacks (adding speed hacks changes very little).
The load on the CPU spikes around 100% for a single core (which I assume is the core being used for emulating) but can still run at 60FPS when at 100% load. The GPU load is pretty low when running the game, hovering around 15 to 30%.

My first idea is that it could be the HDD since last time I went from a HDD (1TB 5400RPM) to and SSD (Samsung 128GB 840 EVO) on my laptop it yielded a significant performance boost, but since the disk load is small (around 4%), my only guess is that it is the response time going from HDD to SSD. The other idea is that the CPU is just not strong enough to run that game without slowing down.


Thanks for any advice you have Smile
Reply

Sponsored links

#2
For me at least (with 5930k 4.4ghz), the MTVU and INTC spin detection hacks really helped me (the other speed hacks however didn't help), maybe try those?
also, after opening PCSX2, change the core affinity to physical cores only, it also may help a little.
Reply
#3
(07-28-2017, 05:34 PM)Assassin47 Wrote: For me at least (with 5930k 4.4ghz), the MTVU and INTC spin detection hacks really helped me (the other speed hacks however didn't help), maybe try those?
also, after opening PCSX2, change the core affinity to physical cores only, it also may help a little.

Just tried these settings. The MTVU helped a little bit, but INTC spin detection not as much. I also tried increasing the EE Cyclerate and still no luck.
Reply
#4
Don't know if this will provide any boost to performance for you, but I'd suggest switching to the OpenGL (Hardware) renderer and setting Blending Unit Accuracy to Basic - this will make Ratchet's shadow render correctly (if Auto Flush hack was on, it can be disabled).

It's possible to get "full speed" in intensive areas by using negative EE Cyclerate settings, but doing so results in choppy gameplay for me.
Windows 7 Home Premium 64-bit | Intel Core i7 4770 @ 3.4GHz | Gigabyte GeForce GTX 770 OC 4GB
Corsair Vengeance 16GB DDR3, 1866MHz @ 9-9-9-24 | 256GB Samsung 840 Pro | 1TB 7200RPM WD Black


Reply
#5
(07-28-2017, 11:02 PM)Dreadmoth Wrote: Don't know if this will provide any boost to performance for you, but I'd suggest switching to the OpenGL (Hardware) renderer and setting Blending Unit Accuracy to Basic - this will make Ratchet's shadow render correctly (if Auto Flush hack was on, it can be disabled).

It's possible to get "full speed" in intensive areas by using negative EE Cyclerate settings, but doing so results in choppy gameplay for me.

Thanks for the tip! I switched to OpenGL and changed the blending mode to basic and it rendered the shadows correctly with Auto Flush disabled. There was no performance increase with this config, but when Auto Flush was enabled the performance decreased by 70%.

Currently what I am noticing is that it may show the correct FPS, because when Auto flush was enabled it showed me 7 to 20FPS, when playing normally it showed 60FPS at all times with the game having lag spikes for short periods of time and no stretched sound. Even when looking at the same area which caused the lag spike it goes away in a second or two. Is this just normal for R&C on this emulator?
Reply




Users browsing this thread: 1 Guest(s)