Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Speed issues on The Sims 2 (too fast!)
#1
Sad 
The problem is that PCSX2 switches to NTSC while running The Sims 2 (PAL), so the game runs too fast. Here is the log:

EE/iR5900-32 Recompiler Reset
Bios Found: Europe v02.00(14/06/2004) Console
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59,94 fps
(UpdateVSyncRate) Mode Changed to PAL.
(UpdateVSyncRate) FPS Limit Changed : 50,00 fps
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLES_537.18;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = PAL
ELF (cdrom0:\SLES_537.18;1) Game CRC = 0x5A43B602, EntryPoint = 0x000FFF50
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLES_537.18;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = PAL
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59,94 fps
(UpdateVSyncRate) Mode Changed to PAL.
(UpdateVSyncRate) FPS Limit Changed : 50,00 fps
Overall 0 Cheats loaded
Overall 0 Widescreen hacks loaded
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59,94 fps


PCSX2 detects the game as PAL, but switches to NTSC, why?
The game runs without any problem, but it runs too fast and it's unplayable.

I have read that I can change the NTSC default rate in the PCSX2_vm.ini. So I swapped NTSC and PAL rates in the config, but when I start PCSX2 the old rates get back and the ini file resets.

What should I do? I'd really like to play this game again, old memories...

PCSX2 1.2.1
Windows 8.1
Intel Core i7-3770
AMD Radeon HD 7750 1 GB GDDR5
6 GB RAM
Reply

Sponsored links

#2
That's weird. I know some Europe games support both NTSC and PAL. You sure that's not the case?
[Image: ov4]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#3
I'm sure that something is going wrong. A real-time minute is not a game hour as it should be, but it's something like 1 hour and 20 minutes. I mean while playing (such as a Grand Theft Auto hour in clock being a real-time minute).
Reply
#4
did you disable framelimiter? or hit tab?
Reply
#5
(09-05-2014, 12:17 AM)tsunami2311 Wrote: did you disable framelimiter? or hit tab?

The frame limiter is enabled (Normal) (around 60 fps all the time) but it should be set on PAL because the game is PAL.
Reply




Users browsing this thread: 1 Guest(s)