Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Sporadic slowdown in a few games.
#1
In PCSX2, I occasionally get tiny half-second slowdowns in parts of the game that otherwise run at 60FPS. This happens infrequently in Dark Cloud 2, and slightly more often in Katamari Damacy.

Usually it will happen for no apparent reason, in an area that shouldn't put any strain on my computer at all.

For reference, here are my specs:

Intel i7 2600K @ 3.4Ghz
Nvidia 560GTX
8GB DDR3 RAM

The only custom settings I'm using is changing the resolution to 1280x720 in GSDX and making the game go fullscreen on boot. Nothing else (except gamepad inputs) have been edited, and I'm not running any speedhacks. I'm using SVN revision 5037.

Both games run at a constant 60 and haven't used up more than 80% of my processor yet. I've only noticed this strange slowdown behavior in fullscreen mode, though; for the hour or so I played before enabling it, Dark Cloud 2 ran mostly flawlessly. Could it be the culprit?
Reply

Sponsored links

#2
Try the official 0.9.8 (4600) and other SVNs and see if you get the same slow down. If you happened to get the same result then it's most likely your gpu. How much fps did you drop from 60?
Reply
#3
(01-14-2012, 08:48 AM)tuanming Wrote: Try the official 0.9.8 (4600) and other SVNs and see if you get the same slow down. If you happened to get the same result then it's most likely your gpu. How much fps did you drop from 60?

I'm guessing to around the 20s, it's enough to distort the audio. But it only happens for half a second in random intervals, spaced across anywhere from 30 seconds to several minutes; it's not related to anything going on in the game, I think.

I'll try 0.9.8 and see if it helps.
Reply
#4
You running off the cd or are you running them as an iso?
Reply
#5
(01-14-2012, 10:30 AM)Topken Wrote: You running off the cd or are you running them as an iso?

An ISO.

Also, I just tried 0.9.8; it has a nasty bug with text bubbles, so I think I'll have to dig through revisions.
Reply
#6
(01-14-2012, 09:48 AM)FlotsamX Wrote: I'm guessing to around the 20s, it's enough to distort the audio. But it only happens for half a second in random intervals, spaced across anywhere from 30 seconds to several minutes; it's not related to anything going on in the game, I think.

I'll try 0.9.8 and see if it helps.

If it only last half a second with random intervals then it's something else. GPU limited tends to last a lot longer than that and it's typically in fights, casting magics, lots of actions going on at once, and/or all the above.
Reply
#7
(01-14-2012, 12:51 PM)tuanming Wrote: If it only last half a second with random intervals then it's something else. GPU limited tends to last a lot longer than that and it's typically in fights, casting magics, lots of actions going on at once, and/or all the above.

It's definitely not the GPU, or if it is the symptoms weren't showing. It didn't go beyond 25% usage the entire time I played.

And the problem is present in 0.9.8 as well.

In Dark Cloud 2, it's very noticeable in Chapter 2, in Future Sindain. The game runs at a constant 60FPS while running around, but if you engage in conversation with Jurak or a cutscene begins, every 30 seconds or so the game will slow down for a very short period of time then speed up, causing audio distortion.
Reply
#8
Sorry for the bump, but the mini-slowdowns have become more frequent. It's almost always when a character is speaking, though. Is there any chance that it's a plugin-related issue with sound? Or a game issue that has yet to be addressed?
Reply
#9
It could be a bug with these games or it could be that Intel's Hyper Threading is interfering with pcsx2. If that's the case then you probably want to disable HT from the bios. Also, try searching for the forums to see if others are having the same issue as you are. And it wouldn't be a bad idea to re-rip the games.
Reply
#10
(01-15-2012, 12:01 PM)tuanming Wrote: It could be a bug with these games or it could be that Intel's Hyper Threading is interfering with pcsx2. If that's the case then you probably want to disable HT from the bios. Also, try searching for the forums to see if others are having the same issue as you are. And it wouldn't be a bad idea to re-rip the games.

How would hyperthreading affect PCSX2? Would I see any performance losses? Just curious, before I disable it.

Edit: I disabled it, the problem persists. Will try other plugins to see if problem goes away.
Reply




Users browsing this thread: 1 Guest(s)