Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Spyro: Dawn of the Dragon (PS2) - weird lighting issues
#1
NEVERMIND, only after posting this I realised the right wording to use in google, and found out about the skipdraw hack that is accessed by editing the GSdx.ini file in the ini-folder. Changed it from 0 to 1 and the issue seems to be gone (it should, right). Sorry for the bother everyone!
__________________
Hello there, seems this site is back up again and I'm finally able to ask this question.

I've just played through the Legend of Spyro series' 2 earlier games without any problems on my computer (by using Aggressive / Aggressive Plus presets to increase fps to enjoyable levels). However, it seems that the third game in the series: Dawn of the Dragon, always has these weird lighting issues no matter which ROM of the game I'm using, I've tried PAL and NTSC, Nordic and European. So I came to the conclusion that it's probably something to do with the emulator itself - and fixable, since this game is rated as "playable" while the earlier games have a worse rating but played through perfectly fine.

Before anyone says anything, I'm a legal owner of both this game and a PS2, they're just at my family's while I live on in my own apartment, and my little brother really likes playing on the console so I don't have the heart to hog it to myself. Tongue2

Basically, in only a small degree of camera angles the game is completely fine, but in most there's this weird light with around half-full opacity making it hard to see through. The light usually encompasses exactly half or 3/4 of the screen (in 1/4 blocks), changing when you rotate the camera. There are some small, more erratic rainbow colour glitches happening too along with the more constant light.

Allow me to show pictures that will probably explain much more than any shortstory I could possibly whip up Tongue2.

First pic: The small angle where the issue isn't bothering the playing experience.
Pics 2, 3, 4: Rotating the camera to the right from the flawless position.
[Image: lightingissue.jpg]

As you can see, you can still see the game even through the light so I have hope that the problem could be easily dealt with.

So is there any available fix for this, some way of fixing/disabling certain light-related features in the game etc.? (Didn't find any in the Configs.)

My specs are:

Windows 7 x64
AMD Phenom X3 8750 (stock clock 2.4 GHz, clocked @2.76)
nVidia GeForce 9800 GT
4 GB DDR2 RAM
Regular 7200 rpm HDD (500 GB)

I've tried running the game both from the "stable" PCSX2 0.9.8 (that is r4600) and the newest revision I could find (r4897), and both have the same issue. (The newer revisions fixed the HUD and menus in the 2 earlier games though.)
I've tried 2 different ROMs: an European NTSC and a Nordic PAL version. Both of them have the issue.
I've tried running the game with Preset 1 (Safest), didn't fix the issue; only dropped my FPS from 50 to 25 when reverted from Aggressive Plus.

If there's anything else I missed, lmk (I tried searching these forums for a similar topic first, no avail). But yeah, is there any way of fixing this or is it a known and accepted issue even though the game's rated "playable"? (Which it practically is, but is pointless with this glitch as games are meant to be fun to play, not torture.)
Reply

Sponsored links





Users browsing this thread: 1 Guest(s)