Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Star Ocean 3 help
#1
Hi guys,

I've looked through nearly 20 threads but couldn't find a solution for Star Ocean 3. On the newer versions of pcsx2 (1.2.1, 1.3), I can create a new game but once it gets to the first cinematic the screen turns blacks every 30s or so, seemingly on the same spots.

I also tried to run on 0.9.6 with the tri-ace fix. I could create a new game but once it got to the first scene the program crashed completely.

Also, on my old laptop I used to be able to play it but with lower fps. Now I have a new laptop and higher fps but I'm getting random black screens.

Any help would be greatly appreciated, thanks.
Reply

Sponsored links

#2
Please post your emulog. And, did you try running the game in software mode ?
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#3
In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#4
Thanks for the replies, do you need the entire emulog or just the end? Also how do you run on software mode?

OS: Windows 8.1 64bit 6.3 build 9600
Model: aspire v3-572g
Processor: i5-4210U @1.70GHz (4 cpus), ~2.4GHz
Memory: 8192 mb ram
DirectX Version: DirectX 11
Graphics Card: NVIDIA GeForce 840M
Reply
#5
Go to gsdx plugin settings and set video renderer to dx11 (software mode) or just directly press F9 while playing the game.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#6
Awesome, that fixed the intermittent black screens! It looks like it dropped my fps from 50 to 25-30 though so I'll have to look into that.
Reply
#7
Set extra rendering threads to 3 and check whether it offers any performance boost or not. And, make sure you have enabled mtvu hack.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#8
I enabled MTVU, but not sure how to set the extra rendering threads. Dang this is rough, if I turn off software mode it immediately jumps to 55 fps haha but then the black screens come back. I wonder if it's just the beginning scene.
Reply
#9
The extra rendering threads option is there at the bottom of gsdx plugin settings. ( under the title of software mode settings).
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#10
Ah, got it. That boosted me from 20-25 to 30-35 fps. Laugh

Edit: Getting 40-45 outside of cut scenes though!
Reply




Users browsing this thread: 1 Guest(s)